Roon won’t log in to streaming services

Core Machine (Operating system/System info/Roon build number)
All latest updates installed.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

First appeared a few weeks ago while running on TP-Link AC1200, currently replaced with

Same results after replacing and setting up a fully new network.

NUC is connected directly into the router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Klimax DS Katalyst, connected via LAN cable.

Description Of Issue

Several weeks ago, Roon gave me a message ‘failed to login to Tidal’. Re-booting of NUC, music streamer, network router did not fix the issue.
After several attempts, my Tidal log-in details disappeared completely from the Services tab.
Further attempts to log-in lead to the message ‘Network error; please check your connection’.
Convinced that this was an issue with my Wi-fi router, I ordered another (professional) device which was delivered and installed today.
However, upon powering up all my network devices, I discovered the issue still remains!
At the same time, music from my NAS streams with no issues.
The router is definitely connected to the Internet, as I am using the same Wi-fi to write this very message.
BTW, I had a temporary account to test Qobuz which also failed to log in at the same time. So the issue is not with the Streaming services.
Tidal runs ok from its own app, or via Linn app.
Please assist, I am frustrated beyond words…

Update: I checked the Roon Version, at it says build 505, with a message ‘There was an error checking for an update’. Seems ROON can’t connect to the Internet at all, even though the ROCK page says all is fine.


Hi @Sergey_Aristov,

If you switch your Core temporarily to a Windows or Mac device are you able to connect to TIDAL/Qobuz in Roon while connected to the network in the same way?

Hi Dylan,

Thank you for prompt response.
I, in the meantime, resorted to a more IT savvy acquaintance of mine. It seems the issue occurred when I was changing my IP from DHCP to static and back. In the process, DNS and Gateway settings dropped.
Now it looks like all is back to normal, I will test and report back if anything.

1 Like

Hi @Sergey_Aristov,

Thanks for the update, do let us know if you require further assistance with this issue or if it still resolved after your tests!

Guys, there is still an issue (which I have had for a very long time), when I cannot play back from the history list.
For example, coming 1-2 days back and clicking the track gives me a message “this track is not currently available on Tidal”, and the same starts to happen to any tracks that I click.
Rebooting the NUC with ROCK solves the problem, but it repeats again in 1-2 days.

Hi @Sergey_Aristov,

Can you please reproduce this behavior and note the exact local time + date + track you try to play that gives this error? And then reboot the ROCK and let me know the new timestamp?

At 5:57 Pm on 1/4/20 tried to play Dark Side Of the Moon
Rebooted ROCK
At 6:04PM tried to play Dark Side of the Moon and it worked

whenever this happens, it applies to ALL Tidal tracks in the historical playlist, not only a particular track.
Please see the screenshot of the last occurence with timing on the top left. Roon starts skipping through the tracks, and then stop with a message.
In this occurence, I rebooted ROCK at 7:00 PM, and all went back to normal.

Hi @Sergey_Aristov,

Thank you for letting me know that timestamp. I have enabled diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis, but I’m not seeing this report being delivered, even though this diagnostics service is working as expected on our end.

Can I please request that you send me a manual copy of your logs by using these instructions? The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service, just let me know and I can provide alternate upload instructions. Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.