Roon Won’t Recognize One Album

I purchased a copy of the “Bach: Famous Organ Works” CD by E. Power Biggs ( and ripped it to FLAC files using dBpoweramp just as I have with hundreds of other albums. I cannot get Roon to recognize this one album.

My music that Roon uses is on a Synology NAS device. I am using a Roon Nucleus server on the same network. I also use Tidal and Qobuz through Roon. I have removed the album and copied it over to the NAS multiple times, stopping the Roon server before adding and restarting the Roon server after doing so. I have renamed the folder to simply “E” and each file name “1”, “2”, “3”, and “4” to make sure it’s not a filename problem. I have restarted the NAS. I have restarted the Roon Nucleus. The Roon Server software is at version 1.8, build 831 and the app version of Roon I am controlling from on my Mac is the same version. The NAS software is up to date.

“Clean up library” says there are no files to deal with. The files do not show up in “Skipped files”. The copy of the files on my Mac play just fine with Audirvana Studio and the copy on my A&K SE200 play fine as well. The files show up properly in Yate.

Any ideas? Thanks! Joel

Try Putting the album on a USB key, plug it into the nucleus and them set that as a new storage location and see if Roon picks it up.

Do you mean that 1) the album does not show up at all, or that 2) it shows up but as “unidentified”? If 2, that’s unsurprising because does not show it at all, which is a common problem with reissue CDs/boxsets that are just reassemblies of existing recordings.

@Rugby - that works! So what does that mean? I tried stopping the Roon server again, putting the file back on the NAS, and restarting the Roon server. Still no-go.

@Fernando_Pereira - 1) the album does not show up at all. The Tidal version does, though.

Try renaming the file before trying to import it again into Roon

Did you do Roon>Settings>Storage>Force rescan after you stored the album rip on your NAS? Updates in a Synology NAS do not propagate reliably to Roon, in my experience. That’s one big reason I changed my setup to use 4TB SSDs to store the music on the core server(s).

@Norman_Spector - thanks, but I did that at least four times…

@Fernando_Pereira - thanks, but that didn’t cause it to find it, either…

I seem now to recall a few similar occurrences when I was using my Synology NAS as Roon storage, maybe the result of Roon trying to index the album before it was fully copied into the NAS. If I remember correctly, here’s what I did then:

  1. Move away the new album folder from NAS storage
  2. Force rescan
  3. Clean up library on Settings>Library
  4. Move back the new album folder
  5. Force rescan

I’ve had this problem several times and have found that importing the album under its full name with a number at the end works; also, make sure you give roon enough time by clicking on the spinning wheel at the top right as the scan is underway

@Fernando_Pereira and @Norman_Spector - I tried deleting the folder, rescanning, etc. and put a number at the end of the folder name, and it still wouldn’t find it. @Norman_Spector, I’m not sure what you mean exactly by “importing the album under its full name with a number at the end”, though. Thanks for the ideas. Got any more???

Have you tried naming the folder “Biggs Bach Famous Organ Works9”

OK, so this is just a bit embarrassing, but not totally… The problem was that Roon didn’t like the name of the parent folder for that album and so, in reality none of the albums in that parent folder were showing up. I renamed it and most of the albums in that folder showed up, but a few still needed tweaking. I found this by looking in My Library → Tracks → and then looking in the Path column. Thanks for everyone’s help!

You’re welcome!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.