Roon wont add last song in album to library

I recently added a new 11 track CD to my library. For some reason my computer had some error and did not complete ripping the 11th song. The first 10 songs were automatically imported into my Roon library but after I ripped the 11th song a day later, nothing I have done will get Roon to add it. I have tried rescanning my entire library, reanalyzing the album, and rescanning the album. None of these steps worked. The only way I could get the last song to be added was to rename the folder. Roon added all 11 songs immediately.

BTW, the album is Until the Hunter by Hope Sandoval and the Warm Inventions (great album!!!)

Sometimes the OS does not inform Roon that the file has been added, Just wondering what device are these tracks store on?

The songs are on my NAS, Thecus N4100Pro.

I had a feeling you would say on a NAS, I’ve found that stopping and restarting the Core helps to pickup “missing” tracks.

I also tend to rip to a staging folder, then once ripped and I’m happy with the file tags, move the files over into the Roon Watched folder.

1 Like

This is a great practice that I employ as well. I also have a staging area for purchased downloaded music.

1 Like

I also have staged folders and drag and drop into NAS. They are my real emergency back up if all the others fail. You can’t have too much back up.
I have accidentally droped a file into back up and not noticed and puzzeled as to why Roon never saw it.
I couldn’t then just drag and drop into Roon_Music. I could copy it from back up though, which I did.
You havnt got to be smart with this stuff, just observant and persistent lol


Whats weird is that this behavior is not consistent. For example, I just deleted a track from a folder and Roon picked up the changes immediately. Also, why doesnt doing a library or album rescan pick up the changes? Shouldnt the album rescan force Roon to look at the entire folder again?

If you go into the Watched folder, can you find the track manually, is it there?

Yes, the track is there. I had to rename the folder for Roon to pick it up.

Then in Roon, just Merge Albums. The original album and the album with the single previously missing track.

But there is nothing to merge. The single track is not added to Roon. Once I rename the folder, the entire album is correctly imported with all 11 tracks.

That’s it then, one of life’s mysteries.

I’m OK with Roon not picking up newly added tracks or albums sometimes. However, there needs to be a reliable way to manually add the missing items. The album rescan features seems like it should do this. Perhaps devs can improve this feature.

The problem must have been with the original folder name. Did it have any special characters?

Hi Chris, I don’t think that was the problem as Roon had already added 10 files from that folder suggesting the name was ok.

The “quality” of implementation of SMB shares across different devices can vary … and sometimes when adding or modifying a file the OS does not report it back to Roon … and hence Room misses it.

That said, a Roon “Force Rescan” should have found this “missing” file.

Exactly. all of my music folders are named the same way, release year - album title.

In general I think the Roon watch folder works very well and adds music to my library almost as quickly as I can copy files to my NAS. Its just sometimes Roon will seem to get into these weird situations that it cant get itself out of perhaps because of some issue with the logic or code.