Roon won't connect to NAS library after power outage

Core Machine (Operating system/System info/Roon build number)
Roon Core v1.6 (build 416) stable (QNAP)
QPKG-Version: 2019-06-09

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Roon core (QNAP NAS dedicated to Roon) is hardwired Ethernet to the same UniFi switch as the PC where music files are located.

Roon Remote running on iPad and iPhone

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
BlueSound Node2i and Devialet Phantom Reactor speakers.

Description Of Issue
After a Power Outage my QNAP NAS restarted and everything came back and it took awhile for Roon to restart. Once the Roon Core was up, my roon remote (iPad/iPhone) displayed a message Waiting for a connection which never went through.

Upon clicking “select a different core” it found the NAS but it wasn’t able to display music. It said the library could not be found. After much trying, I decided to remove and re-add the music file share. This initially took a while but always errored out with a similar message saying it could not access the share.

I restarted the NAS, my PC, the iPad no difference

After much trying I removed and reinstalled both Roon Remote and Roon Core and I now get an error when trying to add the share it errors right away with a different message saying: “Could not connect to share: Unauthorized”.

I verified the share is up and accessible from all other devices including Sonos, Node 2i, my other laptop and from the iPad running SMB explorer app.

Is Roon caching the NAS connection string somewhere and causing this weird behavior?
Any ideas on how to reset the Roon remote so that it sees the share?


Recheck your user ID and password for the share in Roon.

that’s the first thing you have to do when configuring the share

Check the user ID, password and path to the share. Also try using the IP address instead of machine name.

It’d be helpful if you could share screenshots of your share from the laptop and Roon.

I just tried IP address and same result.

What’s interesting is that the error is instantaneous, like it’s not even trying to connect like it was previously. Before re-installing everything the roon remote would take about a minute or longer to timeout after trying to connect and the error was different.

I’m creating a test share to try again and see if that helps

Please share a screenshot of the Windows share settings. Also, can you access this from another device?

there’s not much to it but here goes:

Same problem with a new share I just created from scratch. I also removed and re-added the same share from the BluOS controller and reindexed without issues, so I doubt it’s a share issue.

Adding a share in the NAS seems to work but that’s not where my music is right now. Both NAS (Roon Core) and PC are hard wired to the same UniFI switch.

Looking at the logs here’s where it seems to be failing:

but unfortunately that doesn’t shed any light

The share is “Music” not “music”.

I don’t think it’s case sensitive because I tried different combinations already, but I just tried it again and same problem

I live in Johannesburg, power outages are par for the course…

If I hit funnies I restart everything

The fibre modem and router first
Only when I see all the correct lights on the router do I start the core PC

It normally works.

I suspect our power outages affect the fibre service infrastructure and everything takes a while to settle down,

Last week we had 3 sessions of “load shedding” …

Just a thought

It’s past midnight here in California, I’ll go to bed and try again tomorrow.

I keep thinking there’s something left behind (a config file or setting) in the roon core possibly a corrupted state which is not letting it try the connection.

Thanks @Martin_Webster and @Mike_O_Neill for the assist!

Oh yes they do matter just like passwords

In Linux case is preserved unless the nocase option is specified.

The path should look something like this: smb://ip-address/Music or smb://hostname/Music. Make sure you use

Hi @Luis_Salazar,

Can you confirm how exactly you reinstalled your QNAP Core? Was this performed through the QNAP App Center?

Can you try rebooting your networking gear as well?

Do you still have SMBv1 enabled on your Windows PC? Have you tried different permutations of your Windows username?

I can’t find the thread, but I recall that one user had to place his complete Microsoft login instead of just the username, e.g. instead of just Luis for the username.


Deinstalled and re-installed roon core through Appcenter.

I did reboot the networking gear as well both wired and wireless just in case.

SMB1.0/CIFS Server is enabled on the laptop. Again Sharing works with all other devices in the same network

I have tried both luis and and multiple combinations of uppercase and lowercase. Prior to the power outage this was working fine with the same credentials and sharename

@Martin_Webster I tried the Linux version as well (smb://)

The roon remote is only sending commands to the core to connect to the Library, right? and not really part of the equation so it’s just the roon core the one that’s having the connectivity issues. I just deinstalled the core and noticed it leaves behind a bunch of folders in the volume. I’m going to re-format that 128G SSD volume and try again.

BTW is this the right way of installing the Core and DB?

Finally got this fixed. I reformatted the drive where Roon Core was originally installed so all the old folders were gone and then re-installed the core as usual. It still didn’t seem to like the account I was using (nor the previous “luis1” account I was using) so I also created a new “luisx” account and password and that plus the above took care of the problem. So it does seem to be some weird credential caching going on.

For the record, just for kicks I removed the library and re-added it afterwards with “all lower case” and no problems at all so it is NOT CASE SENSITIVE.

Anyway, thanks everybody that chimed in to help!! I’ve earned my drinks today and that’s where I’m heading now :cocktail:


Maybe not case sensitive on your qnap but on synology and just about every other nas or server I’ve setup they are … anyway you are up and running so happy days.

Hi @Luis_Salazar,

Thanks for the update here and glad to hear that things are working since creating a new QNAP login! I wish you a continued enjoyable Roon experience.

1 Like