Roon won't load - white screen

Roon has been working fine on my PC for years. Recently I upgraded to Windows 11 - I think Roon worked OK after that. More recently I upgraded the motherboard, CPU and RAM on my PC. I don’t think I have loaded Roon since then.

The problem I am getting now is that when Roon loads, I just get a white screen (with Roon in the title bar and the red cross at the top right). Waiting for minutes does nothing. If I click the close button I get the message “Roon is not responding”. If I click “wait for the program to respond”, it just remains on the white screen.

It seems to be in the task manager:

This is technically the Roon remote, as the Roon core in running on a NUC connected via ethernet. I can log into the Roon Core page and it looks fine.

Any help appreciated!

Have you tried uninstalling and re-installing Roon? I assume the W11 PC is your Roon Core? Do you have a recent backup of Roon?

Wow, thanks for the quick reply @Robert_F !

I edited my post - the Win11 PC is a remote, with the core connected via ethernet on an Intel NUC.

I haven’t tried uninstalling and reinstalling Roon. I guess that won’t affect my data, which is all stored on the core?

Yes @extracampine, the W11 PC being a Remote makes this less risky. I would try uninstalling and re-installing on the W11 Remote and see what happens.

Oh, and are you sure Roon is running on the NUC? Is this issue limited only to the W11 Remote?

Yes, Roon core is running on the NUC. I can connect to the NUC no problem with other remotes, e.g. iPad. Just the Win11 remote I am having the problem with.

1 Like

Not sure if this is relevant but I run dual monitors on my PC. Roon Core is on a different PC.
If I open Roon and (for reasons I don’t understand) it tries to load on the secondary monitor I get the same white screen issue and need to force quit Roon, turn off my secondary monitor, open Roon again, turn on the secondary monitor, and drag roon over to it.
From then on Roon will open in that monitor and run properly - usually.

1 Like

Thanks, that was the same problem for me - though turning off the monitor didn’t do it; I had to disable it under display settings. How bizarre. This never happened before - I wonder why now?

1 Like

It’s a recent development for me too and it seems to happen randomly.
I’m wondering if it’s a Windows or Nvidia driver update thing?
I’m on WIN10.


I’m on Win11 with NVidia 1080ti GPU. Maybe the Roon team can look into it.



Good (and simple to try yourself) direction to look…

Has the nVidia driver been updated/or not updated recently?

  • If it has, try going back and/or forward a version.

If the processor has an iGPU:

  • You could try enabling it and using that instead of the 1080, see if the white screen goes away. (This is purely for testing purposes, as your much better off with the nVidia 1080.)
1 Like

I think I last updated the NVidia driver a week or so ago. It gets updated every few weeks or months. The processor has an iGPU, I can test that, thanks.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.