Roon Wont Login, Keeps redirecting to Login Page

Roon Server Machine

Qnap 473

Networking Gear & Setup Details

eTHERNET

Connected Audio Devices

numerous

Number of Tracks in Library

5000

Description of Issue

Can select the Roon Core when launching Roon it prompts to sign in enter correct username and password and it just cycles ,

Tried different browsers as default
Tried restarting Roon Core

What can I do to get going again.

Have you tried turning off pop-up blockers?

Yes disabled pop blockers. It does pop up and give the login. But just cycles until there are lots of tabs open. Tried edge chrome and Firefox. All the same result. Considering others with same complaints on the forums and the fact that this came on without any changes on my end this looks like a Roon. Issue. Granted it’s not impacting everyone but Roon is unusable for me

@accounts Can I get some assistance here?

So how do you get support on this product? It’s up for renewal soon, but I can’t see that happening as its unusable.

What I would like to do now is uninstall and reinstall the Roon Core on the QNAP and then restore from my backup.

Hi @Ian_Pizey,

Thanks for taking the time to write in, and I’m sorry to hear you’re having issues logging in. I see that you’re now using a windows 11 device as a server, are you still having issues?

When you were using your QNAP as a server, what remote device were you attempting to login from? Could you please reproduce the issue and share the specific date, time and name of the track playing when the issue occurs?

Once you let me know this info, I’ll go ahead and enable diagnostics for your account so I can review the logging for clues.

If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.

Thanks!

yes I installed Roon on a windows PC and I did have no issues logging into the PC version.
I tried logging from multiple PCs and mobile devices.

Since I have uninstalled roon on Nas on the QNAp I am now looking to re install it and restore a backup of the database to get all my edits back. Where can I find a copy of the qpkg installer as its not showing up in the QNAP multimedia section.

I have uploaded my logs. Nearest I can tell is it quit working on the 12th.

Hi @Ian_Pizey,

Here is the information, download and primary contact for using Roon on NAS:
https://roononnas.org/en/roon-on-nas/

Issue Resolved. It appears something went wrong with the virtual switch on the NAS and it had no connectivity. So for somebody reading this in the future, test the connectivity externally to ensure its working. Seems basic now that I understand what the solution is, but at the time all seems to be working fine. Roon Server would start, Roon apps and clients would load and offer to connect, at this point the login redirect would happen.

Deep in the server logs I saw a message “unable to connect” this must be when the login process is working.

Perhaps a meaningful message from the Roon interface like “unable to contact Login Server” would have been helpful instead of a continual redirect, that had me checking the other usual culprits like cookies, browsers, cache etc.

At any rate reinstalled , restored backups and all is well in Roon Land.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.