Roon won't play any Tidal tracks but Tidal streams normally from Tidal app

Roon Core Machine

1 x QNAP TS-473A 4-Bay Network Attached NAS Storage Enclosure (8GB RAM)
1 x Seagate IronWolf 510 Series 480GB M.2 2280-S2 M-Key PCIe NVMe SSD Drive for Roon DB
3 x Seagate ST6000VN001 IronWolf 6TB SATA Hard Drive for NAS w/ 5400RPM 6GB/s 256MB Cache
Roon Build 831

Networking Gear & Setup Details

Internet connection is via fast fibre though broadband speed is a maximum of 7.5 Mb/second with a maximum download bandwidth of 80mbps.
Our ISP (Zen Internet)has not found any evidence of bandwidth or latency issues during streaming in their logs.
Single LAN running with DHCP enabled on the Vigor2860 router (firmware IPv6 disabled, DNS configured to point at &, Windows PC & QNap NAS on fixed IP addresses, Gigabit ethernet cable connections.

Connected Audio Devices

Currently for test purposes using PC as audio and music manager. HP Z2 Mini G4 Workstation HP Z2 Mini G4 Workstation - 1 x Core i7 i7-9700 - 16 GB RAM - 512 GB SSD with NVIDIA Quadro P1000 4GB Graphics. Windows 10 Pro. Synaptics HD audio.

Number of Tracks in Library

1 album as test, 10 tracks

Description of Issue

We are UK based and have a recent Roon core set up on a new (roon recommended) Qnap NAS with SSD for the Roon DB.
What we describe below is a simplified test system we set up after finding Tidal would not play within roon on any of our networked digital and audio devices. We have run tests to eliminate any possible network issues but the problem persists.
When roon is opened and Tidal selected all the Tidal information becomes visible but after clicking ‘Play Now’ the blue cursor usually just continually runs up and down the time line. No music plays.
In some cases we get sub-second blasts of white noise, then ‘Nothing Playing’ shows.
roon will play Library tracks saved on the QNAP hard drive and Internet radio stations. During testing we only have one album saved.
Once an unsuccessful attempt has been made to play a Tidal track in roon it is no longer possible to play anything in roon, either local Library tracks or internet radio stations. The system seems to ‘freeze’. After restarting the PC and then roon it will then play local tracks and some internet radio stations, until another attempt is made to play a Tidal track.
We have restarted and reinstalled the roon core on a number of occasions without any improvement.

Hey @Paul_Higson and welcome to the Roon Community :wave:

We’re very grateful that you got in touch to let us know the issue you’re experiencing, but also the steps you’ve taken to figure out what might be causing this.

While your description is thorough, I am left with two questions:

  1. If you try to stream TIDAL in Roon to System Output (make sure to enable it first in Settings → Audio and then select it as a zone), does it work?
  2. Have you tried updating your QNAP to the latest build (880)?

Hi Rebeka, thanks for the quick response. Replies below;
Streaming Tidal in Roon to system output enabled as a zone doesn’t work. The track details are visible but when Play Now is clicked the progress bar blue ‘cursor’ moves up and down but nothing plays. I have a video screen grab available.
The QNAP firmware version is

Hey @Paul_Higson,

Thank you for your prompt reply and for the details as they were about two weeks ago. I’ve just returned to the office and saw it… sorry about the delay.

I was wondering if there was any change at all since then?

Hi Rebeka, no change in the situation here, we still cannot stream Tidal in Roon as described in my previous posts. This has been the situation for over 5 months now. We have run out of things to try.
On the basis of Roon’s recommendations for suitable network and audio hardware we invested nearly $4500 on a high quality music system, yet we are still unable to stream in Roon from the recommended streaming service, even with the simplest set up.
We really need some help, ideas, suggestions here.

Hey @Paul_Higson,

Thank you so much for following up with an update…I had wished it would have been a better one, fitting for a brand new year, but hardly ever problems get magically resolved. I appreciate your patience so far :pray:

As a next step, could you please change your Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS? Does it help?

Hi Rebeka. As part of our testing we have already changed the Router’s DNS servers to Google DNS without any improvements.

Hey @Paul_Higson,

Thanks for following up :pray:

You had mentioned a few times trying out tests and that you’ve run out of things to try. I know this has been going on for far too long, but if we are to make recommendations that help, it would be great to know what it is that you tried already. What I know so far is:

  • restarted Roon
  • reinstalled Roon
  • changed DNS
  • trying to stream to System Output

Is there anything else?

Also, what build of Roon are you running on your QNAP?

If you’re trying to play music from TIDAL to the same audio system (excluding Roon), do the tracks play without interruption?

Hi Rebeka, great news, we have tidal streaming in roon on all our devices! We did yet another reinstallation, checking it was the 1.8 Fall 2021 release, and this time found that we have got full functionality on digital and audio devices.
It has now been working for 3 days.
Thanks for your help, I guess we both hate it when things get fixed and we don’t know why!

1 Like

Hey @Paul_Higson,

Wow! That’s awesome to hear :dancer:

It’s really hard to feel bad we don’t know more specifics, when everything it’s been working for 3 days. I’ll leave this thread open, just in case you want to share any other updates.

Thank you for relentlessly working on this with us and even without us :pray:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.