Roon won't play on certain endpoints

Roon Core Machine

HP Spectre laptop with intel i7, 8GB RAM, running windows 10

Networking Gear & Setup Details

ORBI router

Connected Audio Devices

iphone, Sonos music streamers, Denon AVRs (each with HEOS built in), Google Nest and Amazon Alexa smart devices

Number of Tracks in Library

5K tracks

Description of Issue

My Roon won’t connect to one of my Denon AVRs, but it will connect and play to all other devices in my system (including the other Denon AVRs). When I try to play music through Tidal to one of the Denon AVRs (I have 3 of them), it looks like it’s going to play for a second, but then immediately stops. The “play button” graphic ( |< > >| ) changes from an arrow to the “pause” line ( |< || >| ) for a fraction of a second before changing back to the arrow graphic.

According to Roon, the AVR is listed in “other network devices” and is connected through Airplay. I can select any other network device, whether it streams through airplay or Chromecast streaming and it will play, but not with the Denon AVR.

I also have a Sonos:Connect (gen 1) connected to the AVR as a media streamer. It shows up as “Roon Tested” and plays via Sonos Streaming. Roon will allow me to select and play songs through that device, though it won’t let me select/play through the AVR itself.

What could be causing the issue and how do I resolve it?

@NewGuy, welcome to the Community. A fellow user here, but can you provide the model number of the Denon AVR to which Roon is not playing? How is your Roon Core connected to your network, Ethernet cable or WiFi? And how are both this specific Denon AVR and Sonos:Connect connected to your network, Ethernet cable or WiFi?

Thanks for the welcome, Rob. Good to be here.

The Denon AVR that’s NOT playing is an S760H. The two AVRs that Roon does play through are both X4700H

Roon Core is connected via Wi-Fi, as are both the AVR and the Sonos. The Sonos is connected to the 760H AVR’s Media Player input via RCA cables, if that matters.

The Core/laptop doesn’t have an ethernet port, so I can’t connect it to directly to the network; WiFi is the only option. If necessary, both the AVR and Sonos can be hardwired, as it’s close enough to the router/satellite to allow that with relative ease.

Also not sure if this matters but I can only control the endpoint’s volume through the Sonos App (or physical button) and the AVR’s volume dial or remote control (Is that normal?).

The Denon app on my phone has no effect on volume, nor does the volume control on either the Core or my iPhone (iPhone 12 Pro Max running iOS 16.2).

Thanks for any advice you can offer!

I believe the S760H is able to play from Roon only using AirPlay (The Denon is Roon Tested, not natively Roon Ready). Have you enabled AirPlay in the 760’s AirPlay settings?

Can you provide any more information on your Orbi network, such as how many devices are connected and where the 760 is connected? Are the Orbi’s connected to each other via Ethernet cable or only via WiFi?

AirPlay is enabled in the 760.

The Orbi mesh network consists of an RBR750 router, and 4 RBS750 esatellites (I know, we probably don’t need that many - The home is a roughly 3100 square foot ranch, including the finished basement, but we run a lot of outdoor devices). The RBR is hardwired into a surfboard S33 cable modem with DOCSIS 3.1. The satellites are all linked via wi-fi. Internet service is provided by Xfinity.

Currently, there are 47 devices online and connected to the network (I have a lot of Hue lights and Lutron switches). The 760 is connected to a satellite located in the great room (on the main level, near the center of the home), where I originally had installed the 760. Last week, I moved the 760 to my office, which is on the same floor but on the far corner of the home. FWIW, both the Roon core and the Sonos itself are connected to the satellite located in my office.

Let me know if photos or screenshots of anything would be helpful.

Thanks again!

PS: I solved the volume “issue” - User error responsible!

1 Like

Without knowing a lot more about your satellite locations and what devices are connected to them, there may be some things to look at that may help.

Your network has 5 mesh devices covering a single-floor home. Just conjecture, but there may be one too many satellites, or they may be too close together and interferring with each other. WiFi, unlike wired Ethernet networks, can have problems when too many access points (satellites) are active and/or too close together. Also, since all of the satellites are connected wirelessly back to the main router, they may not all have the same bandwidth (the ones furthest from the router may have less capacity and throughput than the satellites closer to the router). Again, these are generalizations and I’m not sure if they apply to your network.

Do you separate your 2.4GHz WiFi band from your 5GHz WiFi band? The 5GHz band has more capacity and is less crowded (especially as many IoT devices use the 2.4 GHz band for cost reasons). I separate my bands and use the 5GHz band for my most critical devices (such as Roon and Roon endpoints). Can you force the 760 to use the 5GHz band?

Have you tried rebooting your Orbi network (router and all satellites), as well as your Roon Core and all endpoints? Sometimes the network may need to reconfigure or optimize, and by moving your 760 this may improve the ability to connect to your Core. Is your Sonos:Connect used for anything other than with Roon to connect to your 760?

1 Like

Hi @NewGuy,

The tech support team is standing by to do a log pull from your Core to investigate this endpoint dropout issue more thoroughly, but first we wanted to check:

Are you still having this problem with your Denon endpoints? If so, did you have a chance to review @Robert_F’s suggestion above concerning the WiFi bands on your router?

We’ll be keeping an eye out for your response. Thank you!