Roon won't play on my Meridian speakers, others work fine

I have a puzzling situation that started yesterday: Roon won’t play through my Meridian speakers, though it plays just fine on my Sonos players–including the ones that also feed the Meridians. When I cue up an album, either from my collection on the QNAP or through Tidal, and click start, the start arrow icon changes to a pause icon, but the time counter doesn’t start running and no music plays. I can drag the slider and the time counter changes, but it still doesn’t play. This happens whether I use my iMac, iPad, or iPhone to control Roon. I can see the purple dot and all the components indicate high quality. The display on the speakers and on the Meridian AC200 both show that Roon should be playing…but nothing comes from the speakers. Fiddling with the Meridian app on my iPad/iPhone doesn’t help. When I switch to playing Sonos or TiVo through the speakers, everything sounds fine. I’m running Roon 1.5 on a SSD connected to a QNAP 251+ NAS, which runs through the AC200. I have a pair of DSP 5200.2 and a pair of DSP 3200.2, each with a Meridian 218. My network is rock solid with Eero connected directly to the Comcast modem (275Mb download speed, 12 upload).

Any thoughts?


You have selected the M endpoints (ie the 218s) in Roon, haven’t you?

Are you running a Sooloos Core at all?

Yes, and no. The system was working fine until yesterday, maybe the day before. When I start Roon, the Meridian speakers switch to the correct input. I did start out with Sooloos but changed to Roon after a couple of weeks back in Feburary, and all Sooloos files were deleted. Again, though, it was working fine up till now, no other settings have been changed.

I wonder if this could have been related to the 1.5 upgrade–it’s possible this was the first time I tried to play the system since I upgraded the controller on my iMac. I’m not sure how the core gets upgraded on the SSD connected to the QNAP, or how to check if it is. Or maybe this is unrelated. I’m confused.

Hello @Mark_Cohen,

Have you attempted a full power cycle (unplug unit from wall, wait 60 seconds, plug back in) with the Meridian 218? When you go to the 218’s web configuration page, does “SLS” show as the current source when Roon is attempting to play to the device?


Thanks, John – power cycling the 218s did the trick!