Roon won't Play Tidal MQA albums or songs with Procedural EQ operations engaged [Investigating]

I am a new Roon user (8 days left on the Trial).
My set up is that i am using a Macbook running MacOs Big Sur 11.6 as my Roon Core, directly wired to a Google Wifi device (home network is Google Fiber), and my 1 wired endpoint is a Sonore microRendu 1.3 connected (hardwired) to an internally wifi networked Google WiFi bridge, which is in turn connected via USB to an iFi micro iDSD Signature, with HIFIMAN Arya as my driver. The iDSD is set up as an “MQA renderer only” and I identify it as such to Roon.

Roon Remotes = 2 iPhones and 1 Macbook Pro. When I first downloaded Roon (current version) TIDAL was working fine, all TIDAL MQA albums and tracks played without problem.

I made some changes in DSP while using the above set up on Roon, after which Roon would not play any TIDAL MQA albums or tracks at all. I kept getting the message “Unexpected error communicating with Audio Device” then “Too many failures, stopping playback”. The MQA albums and tracks all played fine on other endpoints, so I figured out it must be a problem with my microRendu/ifi micro iDSD set up.

Long story short: when connected to the mR/iDSD set up, I reverted my DSP settings back to default values , and voila, all MQA files played totally fine again. Working back through my DSP changes to figure out which one was the problem, I found that MQA play stopped after I added the Procedural EQ “Volume” operation, by which I had added Surround Left and Right (with gain of 1 DB) as I really liked the change to the Soundstage this produced with the Arya. When I activated this, and tried to play an MQA file, I got the error message again. When I deactivated it, the MQA files played again fine- so culprit found. Other elements of DSP seem to work fine with MQA files ( i.e. Sample Rate Conversion with 'Max PCM rate" , and main DSP “Parametric EQ”) and do not have a negative effect on MQA playback- only the Procedural EQ operation. What is there about the Procedural EQ Volume operation that is causing the “communication failure” between Roon and my set up, so that MQA files (only) won’t play with it engaged?

Note if I activate the Parametric EQ Volume procedure for playing FLAC files (including TIDAL FLAC or my own Core library files that include MP3, AAC, and ALAC files) - everything works fine- I just need to remember to “turn it off when I am done” (the Procedural EQ) and not mix MQA into my listening with it activated.

The strange thing (if I recall correctly, perhaps I am not) is that Roon was in fact playing MQA files with the Procedural EQ Volume procedure engaged before today. I did reset my Network today (after updating the Macbook server MacOs to the current version of Big Sur 11.6) --though I would not think that would have had an effect on MQA playback via the microRendu/iFi micro iDSD, as all my MQA files are streaming/added from TIDAL.

Hi @JOSEPH_LEMASTER , I’m going to tag @support here as this isn’t flagged as a support issue. While you wait for a response a screenshot of the signal paths may help them to help you.

Signal paths for current set up for FLAC files without Procedural EQ)

For MQA without Procedural EQ

For FLAC with Procedural EQ in action

Note that signal path for MQA with Procedural EQ is impossible to show, as Roon won’t play the file when procedural EQ is activated, only FLAC (or other non-MQA files) will play.

“Multichannel MQA” is not supported in Roon.

1 Like

So I gathered- is this response then saying similar to what I say to my patients who say “Doc, when I do that (whatever movement it is they are doing) it hurts”…“Don’t do that” ? I guess I can just say “pls can we put it on the wish list for future Roon updates”

1 Like

If I select 5.1 multi channel, and then set “Send stereo content as 5.1” to OFF, MQA tracks will play. They will not play if it is set to ON.


Sorry not following you here- I am still new to Roon. Please specify where in DSP menu this is- is it a different operation in Procedural EQ- I don’t see this in any of the current options I have activated.

Settings / Audio / click the device settings for the audio device under discussion, scroll down, click on Advanced settings, scroll down until you get to the options I mentioned. At least, that is where those options are for me; Roon does morph options depending upon DAC capabilities.

1 Like

For my microRendu device, the “multi-channel mixing” options are “Channel mapping only” or “Downmix as needed” I have tried both and neither allow MQA play if the the Procedural EQ Volume operation is active. I think this all may be ‘audio devlce’ specific- it seems possible that even a different Sonore streamer might have different settings. For instance, the max PCM rate for this 1.3 mR is 384KHz, and the current mR model (1.5) has max PCM rate 786 KHz (though maybe PCM=384KHz max is a Roon max)?


Thank you for the report here. I’ve been in touch with our hardware team and we’ve been able to reproduce similar behavior to what you describe in the lab.

As per policy, I can’t comment on when tickets will make its way through the dev queue, but thank you for bringing this one to our attention!