Roon won't play Tidal music - just sits there

Roon Core Machine

Roon won’t play Tidal. When I hit play, the a purple light in the time bar below the controls bar just keeps moving back and forth. After 20 minutes or so, I MAY get a message that Tidal meeting is not loading because of network connectivity issues.

Thinking about buying a Nucleus, but this problem is really frustrating. How does the software just stop working?

Networking Gear & Setup Details

Connected Audio Devices

Tidal. I don’t know how many track Tidal has. It is the only thing I use Roon for.

Description of Issue

NOTHING WORKS - cleared the cache. Cleaned up the library. Deleted the software and reloaded it. Rebooted. Rebooted. Rebooted. I hit play and get the purple line moving back and forth.

Hey @Donald_Laackman, welcome to the community :wave: and thanks for letting us know of this frustrating behavior.

If you try to play music from TIDAL, outside of Roon to your Mytek Brooklin, does it work?

Tidal works great on its own. This is on the same MacBook that I use as my Roon core. No issues with Tidal on its own.

I also stream to a Brooklyn Bridge, and Tidal works using MConnect, but not Roon. Same behavior - Using Roon, a song will play for 10-40 seconds, and then I get a message saying that Roon detects a Tidal issue (Network?). If I immediately switch to Tidal, it works fine.

Had a chance to try this on a different network - same exact problem. Any updates?

I have the same problem. After 6-10 seconds, Tidal stops playing…

I am having the same issue. When I go to the roon settings/services/tidal and click on the edit tab, says signed but under the streaming quality it says , no stream formats available to you

Hi @beka ,

Any updates? 28 days in, and the problem still happens. I have switched to MConnect to stream Tidal to my streaming device, since Roon doesn’t work in two locations. MConnect works great, except the interface is not nearly as nice as Roon - but I experience no drops, skips or network connectivity issues, all issues that Roon has every time I try to use it.

I have deleted my cache, re-installed Roon, reset my network (in two different locations). Still the same problem. Every morning, I boot up Roon, play my test track, and some time between second 30 and 60, I receive the error message.



Hey @Donald_Laackman,

I’m very sorry for having missed your post… :pleading_face:

Thanks for trying all those steps already. I am hopeful you have some energy to try one more step?

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Thanks a bunch :pray:

I tried this, and the issue still occurs. Thanks for checking back.

Hey @Donald_Laackman,

We’re sorry to hear that you’re still having issues while trying to play from TIDAL. We definitely want to get this cleared up so you can get back to enjoying that Elvis comp!

What you’re experiencing is typically due to network issues, I’ve actually experienced this issue myself at times when my daughter is conquering all the known kingdoms in Zelda!

Please take a look at this article on best networking practices from our Help Center for tips on resolving this.

To start let’s try doing a simple full reboot of the Core machine and router:

  • Power Down
  • Unplug the machine
  • Wait a couple minutes (make a tea or coffee)
  • Plug back in
  • Power up and see if that helps.

We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. TIDAL recommends this, can you please give this a try and let me know if it helps?

Thanks, @Jamie. Rebooted the router, ROON worked for one song, and then stopped again. I tried changing the DNS server on my Mac (Xfinity hard-codes the DNS server and I can’t change it on the router). Roon didn’t play at all. I changed it back, deleted the Roon Cache, re-opened Roon, and now Roon does not play any music. Rebooted the router again, and it still does not work at all. Network for all other services works great. Tidal works great.

Hey @Donald_Laackman,

Can you please ensure that you’re not online in TIDAL on another device? That sounds like it could be your problem. TIDAL only allows one device to be in use at a time. If you’re playing or testing TIDAL while trying to get it going in Roon that could be the issue you’re having. TIDAL has more information on their FAQ page here:–%20TIDAL&text=Getting%20Started-,How%20Many%20Devices%20Can%20I%20Use%20Simultaneously%3F,devices%20in%20offline%20mode%20simultaneously.

Hi @jamie ,

I killed all Tidal connections on all devices, restarted Roon, and had the same problem. The error message (attached) says Tidal media are loading slowly.


One month later, and Roon still not working. I have tried it on two different networks with the same problem. It is either a software issue with Roon, or something about my computer set up. I am running Roon on a 2019 MacBook Pro 16 inch, macOS Monterey version 12.0.1, 32 GB of RAM.

Any thoughts?

Hi Donald,

I don’t have the BB, however, remember reading on here somewhere that there was a firmware update from Mytek’s EU ex partner (HEM) which no longer made it Roon Ready compliant. Apparently HEM pushed this update without Mytek’s consent.

Not sure it your issue and this firmware are related.

1 Like

same issue here and until today still no any solution or update from roon

Hi everyone, I’m having the same issue on my Mac core, build 831… tried applying all the troubleshooting steps seen on other threads, still no resolution. No playback issues at all when I switch the Core authorization to my Windows machine on the same network. Still waiting a response from Roon on my support thread started last week.

Hey @Donald_Laackman, sorry to hear that the issue with TIDAL is persisting! Thanks for trying all of the steps we suggested. At this point, I think we’ll need more information about your setup, specifically networking gear.

Please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

I also wanted to share with you that we released an update yesterday, Roon Version 1.8 Build 880 - could you please update your devices to this version and see if the issue persists?

Thank you!

A post was split to a new topic: Tidal music would not play

I downloaded build 882; still have the issue.
I am not a networking expert. I have an Xfinity router, with a connection from the router to Google Home devices. They run a mesh network. My Roon core is hard-wired to the network Google Home device. Xfinity clocks my download speed at 232.2 MBPS. I am running macOS Monterey 12.0.1.

1 Like