Roon Won't Play To Raspberry Pi Endpoint

Roon Core
Mac Mini, Late 2012
Processor: 2.5 GHz Intel Core i5
MacOS Mojave version 10.14.6
Roon Version 1.6 (Build 475)

Roon Bridge
[Ropieee] (
Version 1.0 Build 169

Allo Digione Signature Player with coax connection to Metrum Acoustics Adagio DAC

I’ve been playing to the Allo Digione Signature endpoint for about a month now with no issues. This has been my first experience with Roon and it has been flawless. All of a sudden, there is no playback at all from the endpoint. Songs will line up to play, sit for a few seconds with no playback, then skip to the next song. This continues indefinitely.

I’ve tried rebooting the core and the endpoint with no luck. My connection is through wifi which has always been extremely reliable at my house. I do have an iPad set up as a second endpoint and that seems to work perfectly fine. Any suggestions on what might be happening with streaming to the Allo DigiOne player? Thanks in advance for your help.

Sure, I’ll give that a try.

No luck… I connected with ethernet and disabled wifi but I’m still having the same playback issue. Roon sees the endpoint as soon as it comes online, but once I hit “play” on a song it just sits there and won’t play. Then it goes to the next song after 5-10 seconds.

Maybe it’s worth sending Harry @spockfish a feedback under advanced in the ropieee settings to see if he can see any issues. What version of ropieee are you using?

At least in my setup, this behaviour has been indicative of a problem at the network level. Just as a test, could you try plugging the end point into the same switch as your Roon core?

Thanks so much for the replies so far. This is the version of Ropiee I’m using right now:

[Ropieee] (
Version 1.0 Build 169

I typically have excellent wifi throughout the house. It’s always been extremely fast and stable.

I’ll try messaging Harry, sure thing. Couldn’t hurt. I’m also going to try flashing a new SD card to see if that helps.

I’m sorry, I missed your comment. I do have the end point plugged into the same router as the core and I’m experiencing the same issue as when it was on wifi.

In the RoPieee GUI, go to the Advanced tab and submit feedback for @spockfish. Post the ID here.

Thanks… Here is the ID: a51bb93792cdf1f1

I just tried installing a fresh SD card with RopieeeXL and I’m getting the exact same issue. I’m starting to think this could be a hardware issue with the Allo DigiOne Signature. I posted the issue on their support forum.

This is why I suggested the feedback to Harry…

Thanks @wizardofoz. I did take your suggestion and sent him feedback through the UI of Ropieee.

As a quick update, I also tried sending a Spotify stream to the DigiOne using the RopieeeXL OS. The stream looks like it’s playing just fine, but I’m getting no audio. This might end up being a hardware issue. I wonder if something happened to the player.

A new ID including data from when I tried Spotify: 5330f0a0273e439f

Moving this to the Allo might be more appropriate so keep us posted. Harry is still in bed probably so might not get the feedback till later in his morning (he is in Holland)

Is the power to Allo unit connected and on? Not sure if its separate power or not.

Thank you… Yes, the Allo is powered on and I’m on the RopieeeXL interface.

It definitely doesn’t seem to be a Roon issue, but all of the advice here was very helpful when it comes to isolating the problem. Once I connect with Harry I’ll have a better handle on it, and hopefully Allo will be helpful as well.

I’ve had great experience with the Allo guys support over the years even replacing something after the warranty had expired - but I did advise them of the issue before it expired. They are on here too so I have tagged them here for you. @ALLO_audio_boards @rahulkc_s

They are all (IIRC) in India so maybe not quite up and attem yet :slight_smile:

1 Like

It’s not exactly clear what’s going on, but RoonBridge is crashing.

So… is it possible to just go back to RoPieee (XL complicates things only when looking for errors) and go back to a wired setup? And see how that goes?


@spockfish, thanks for your reply. I just took apart and re-assembled the Allo DigiOne unit and re-installed the standard RoPieee OS in a wired configuration. Here is the key: 8c36ed5dd25d4281

Please let me know if I can provide any additional information. Thanks again.

So how does it perform in this setup?

Still doing the same thing. Each track loads but makes no progress and there is no audio output. After a few seconds the next track loads, then does the same thing. I did connect with Allo and sent them the output log. They are checking it out as well.

yeah I see some I2S sync errors in the log. Not sure though it that might be the problem.