Roon won't recognize Chord ASIO device

I am having difficulty getting my new Chord DAVE DAC to work with Roon. Prior to the DAVE, I was using HQPlayer together with Roon and an Auralic Vega DAC. I have disabled HQPlayer in Roon. I have installed the Chord ASIO driver, which Roon appears to recognize (see attachment).

My Windows 7 PC is connected to a switch, and then to an SOtM sMS-200ultra and tX-USBultra and then DAVE via the USB input. (I have changed the sMS-200ultra output setting from HQPlayer to Roon Ready.)

All I did was remove the Auralic Vega DAC and replace it with the DAVE. (In other words, I used the same power cord and USB cable. Nothing else changed in my system.)

I have done several re-boots and uninstalled and re-installed the ASIO driver (followed by a re-boot). The result is always the same.

Do you see the Sotm as a network endpoint? It should be acting as the Roon Endpoint with the Chord being connected to it and that is what you want to enable. You chopped the screen pic before we could see.

The section you are referencing is for devices directly connected to the Core computer. The device initialization is failing because the computer is expecting it to be plugged into a USB port on the computer.

I would start by simplifying the path and remove the tx-usbultra and just have the DAVE plugged into the Sotm.

Is this what you need to see? There is nothing showing as networked.

I can get it to work with the sMS-200ultra only. As soon as I put the tX-USBultra back in the system, I lose the Roon endpoint.

I know others are using the sms => tx => DAVE with Roon, so it really shouldn’t be an issue for me. I don’t understand it. Plus, it has always worked before with HQPlayer.

Hello @Brian_Schultz,

Are you able to play to DAVE when it is connected to the tX-USBultra -> sMS-200ultra using it’s other networked input options such as Airplay?

Installing the ASIO driver on your PC shouldn’t have any effect on the behavior you are seeing. The ASIO driver would only come into play when you are using the DAVE connected to your PC via USB directly.


Hi John,

Thanks for your response, and I apologize for not replying sooner. It has been a busy week.

I was eventually able to isolate the problem to a setting on the tX-USBultra, and DAVE and Roon are now working fine.

Best regards,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.