Roon won't recognize my Sonos One SL speaker

Core Machine (Operating system/System info/Roon build number)

Synology Nas DS1819+/ Roon 1.7 (build 528)64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

synology RT2600

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

sonos one SL wifi

Description Of Issue

roon can detect the speaker

tried powering everything off and on again? yes even your modem too!

Hi @kim_wai_pong,

Are other audio device able to properly be detected from your Core?
Is there any change if you temporarily connect this Sonos zone over Ethernet?

Other audio device can be detected by my core.
Plex can detect this sonos speaker but not roon.
when i connect this sonos speaker over ethernet, cant detect too.

Hi @kim_wai_pong,

Do you have Plex running at the same time as Roon? I have seen issues in the past since both Plex and Roon try to use port 1900. Can you try to temporarily exit out of Plex server and let me know if that changes anything?

stop my plex server but no changes.

Hi @kim_wai_pong,

Do you have any other PCs around the house? Can you please try temporarily hosting the Roon Core on the other PC and verify if the same behavior occurs there? I’d like to see if this issue only impacts the QNAP Core or for any Core on the same network. You can use these instructions to switch the Core over:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Yes, it work with PC as the core. Can recognize the sonos one SL speaker.

Hi @kim_wai_pong,

Since the PC is able to properly recognize the speaker, I would suggest first creating a Backup of your Roon database and then reinstalling the Roon app on the QNAP.

I have try to reinstall the roon app on the synology DS1819 SSD drive, but still cant recognize.

Hi @kim_wai_pong,

Since this issue only affects the Synology, can you confirm if you have any firewalls active on it? Or any other apps which may be trying to connect to the Sonos speaker?

i have disable the firewall, but still cant recognise.
Plex, emby and even synology audio station can detect the speaker but i prefer the sound quality of roon.
Are sonos one SL speaker is not compatible with roon ?

You said you tried roon on a pc and it could see the Sonos, so obviously roon is compatible. The problem is your set up on the Synology.

Thank you. I will refer this issue to synology.

1 Like

Hi @kim_wai_pong,

Reaching out to Synology is a good idea. One other thing I would check is to make sure you don’t have Open vSwitch enabled in the Synology settings, as this setting has caused similar issues in the past.

1 Like

Yes, after disable Open vswitch in the synology settings, reinstall roon and restart synology, the problem solved. The sonos speaker can be detected. Thank You very much, Mr. Noris.

2 Likes

That’s fantastic news @kim_wai_pong, glad to hear you resolved the issue with my suggestion!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.