Roon won't start after Windows Update. Was fine before

Core Machine

Windows 10
Intel i9-9900
Both integrated graphics (Intel 630) and NVIDIA Quadro Pro 630

Network Details

Ethernet. Gigabit connection.

Audio Devices

Just this PC

Description of Issue

After a Windows Update, I can’t load Roon on this PC anymore. At first, a dialog box would pop up and tell me my OpenGL wasn’t up to date. So, I updated and installed all of the latest graphic display drivers. Updated everything I could on this PC. Now, the dialog box doesn’t pop up. Nothing happens when I try to open Roon now.

I’ve tried uninstalling and installing again to no success. Roon has been running fine for a year on this machine until this past Windows Update. Trying to figure out what I need to do.

Here’s my latest log:

05/03 10:25:55 Info: Starting Roon v1.8 (build 790) stable on windows
05/03 10:25:55 Info: [URI] Checking that FriendlyAppName == Roon
05/03 10:25:55 Info: Registering for URI scheme: Roon, roon
05/03 10:25:55 Info: URI scheme executable path remains "C:\Users\Me\AppData\Local\Roon\Application\Roon.exe" "%1"
05/03 10:25:55 Trace: Checking if we are already running
05/03 10:25:55 Trace: Nope, we are the only one running
05/03 10:25:55 Info: Is 64 bit? True
05/03 10:25:55 Info: Loading broo project: ui.broox
05/03 10:25:55 Trace: [realtime] fetching time from NTP server
05/03 10:25:55 Trace: [broo/imagecache] loaded 0 cache entries from C:\Users\Me\AppData\Local\Roon\Cache\brooimages_1\index.db, current: 512mb / 0mb
05/03 10:25:55 Trace: [orbit] init seq=0, pending=0, spcount=7, uidcount=1
05/03 10:25:55 Info: [broker] starting cc7623a8-4e91-448c-8f9c-c55aa3c165eb
05/03 10:25:55 Trace: [realtime] Got time from NTP: 5/3/2021 3:25:55 PM (3829044355718ms)
05/03 10:25:55 Trace: [realtime] Updated clock skew to -00:00:00.0399263 (-39.9263ms)
05/03 10:25:55 Trace: [httpcache] loaded 0 cache entries from C:\Users\Me\AppData\Local\Roon\Cache\httpcache_2.db, current: 0mb / 128mb
05/03 10:25:55 Debug: looking for *_old files in: C:\Users\Me\AppData\Local\Roon\Application
05/03 10:25:55 Debug: looking for old numerical version dirs in: C:\Users\Me\AppData\Local\Roon\Application
05/03 10:25:57 Info: [stats] 4832mb Virtual, 198mb Physical, 2mb Managed, 672 Handles, 30 Threads

Then, nothing happens. I can use Roon Bridge, but I need the graphical interface instead.

Suggest you look to the intel and nvidea sites for latest drivers not rely on windoze options

I should have stated that I grabbed my latest graphic drivers from both Intel and Nvidia. Thank you!

The only other thing that I can think of to mention is that I have a 3 monitor setup. 1 goes into the Nvidia card, the other goes into the integrated graphics (the Nvidia card only has mini-display port inputs).

But, this hasn’t affected Roon in the past.

Any graphics accelerator or suchlike? What about if you disable the other monitors

Disconnecting all monitors to the integrated display and only using the Nvidia card allowed Roon to open!

I plugged the other monitors back in and Roon is fine now. Until I get mini-display port cables plugged into the other 2 monitors so everything is on the Nvidia card, I’ll have to disconnect them to launch Roon and then reconnect.

I’m assuming that once all monitors are plugged into the Nvidia card, hopefully I should have no issues. Thank you!


Support will maybe have some things they want you to do but at least you are up for now

1 Like

Hello @Stephan_Pearce,

I am mortified that it’s been over a month since you got in touch and we only had a chance to reply today. Please, accept my sincere apologies - we’ve entirely missed on your post… :pleading_face:

It looks like you’ve made great progress in just a day - thank you for your efforts and for engaging with the Roon community! A big thank you to @wizardofoz for making suggestions :pray:

I was wondering if there is anything left that we could help with :pray:

Hey @Stephan_Pearce,

Is there anything we can do so you can enjoy Roon to the fullest? :nerd_face:

This topic was automatically closed after 45 hours. New replies are no longer allowed.