Roon won't start on Macbook

Mac OS Catalina ver10.15.7

Description Of Issue

Roon v1.8 doesn’t start-up correctly on my Macbook. It launches and only gets so far as the Roon icon continually moving. It’s not a matter of Roon not responding i.e. I can quit the application without forcing quit.
No music in the house!!!

Please HELP!

I’m also having issues. Roon just will not start up on my Mac. I’m running Mac OS Big Sur Version 11.2.3
I just updated the OS this evening hoping it might resolve the problem, but it still won’t start the program. I was running version 11.2.2 just before when the problem arose.

I finally got it to start-up after 10+ tries. I have little confidence that this problem will not pop-up again. Hopefully we’ll hear from support on this.
I’m running Catalina and will update to Big Sur shortly…

I’m also having the exact same issue using Macbook Air 2020 Big Sur 11.2.3 as roon core. All I get is a moving roon logo and nothing else.

48 hours now and still no Roon :frowning:

Not sure if this is related but I also have an issue starting roonserver on macbook Catalina. In my case when I check the menu bar status icon dropdown it continously alternates from starting to error. I have not been able to play music since the day of the launch.

I waited to see if a fix would show up since I thought others must be experiencing this too. Eventually I posted a ticket. A shout out to Slim_Fizshguttz who tried to help but no official response than that.

I did try a fresh install of Roon (not the server) and it comes up ok but of coarse I really want roonserver to work and have my library vs a fresh install of roon.

I recently had the same problem, ie white screen with oscillating Roon icon in the middle and nothing else. This first arose using Mojave and persisted after upgrading to Big Sur so I don’t think it’s a OS issue.
I tried a number of possible solutions including re-booting everything, checking that Arial is enabled on Mac, ensuring firewall off, giving Roon Full Disk access, etc. Nothing worked.
Finally, found this solution which involves a full re-install of Roon. Note that this will wipe all your playlists, etc. Fortunately, I had a backup.

  • Quit Roon
  • Navigate to Roon’s Database Location (Finder>Go>Library(hold down Option key)> Roon/Roon Server
  • Rename Roon/RoonServer folder to “Roon_Old”
  • Restart/reinstall Roon
  • Restore from backup.
  • Re-establish connections to Tidal, etc, and set audio devices
    After 3 days of tearing my hair out, I have a full functioning Roon again.

Hi Grahame

Thank you for your help. Unfortunately I can’t locate the “Roon/Roon Server” you refer to. I have attached a screenshot below. Prior to seeing your post, I had uninstalled and then reinstalled Roon to no effect on the issues being experienced. Any suggestions gratefully received.

Your screen shot looks like the Roon database folder in Library.
If so, and provided you understand that the procedure I’ve outlined will eliminate your playlists, settings, etc (ie you will effectively be installing Roon for the first time), then right-click on that folder and re-name it “Roon_Old” or similar. This essentially nullifies the existing Roon database. Then restart Roon. It will rebuild a new database. You will need to know your Roon log-on details to do this. This should get Roon going again. If you have a Roon backup, you will be able to restore your playlists.
Good luck

Hi Grahame, thank you so much for your help and for getting back to me so quickly. It’s greatly appreciated. I shall try this as soon as I finish work this evening and update with result. Thanks again.

@Grahame_Miller Thank you for the prodding.

I decided there is no support coming so I better just reinstall from fresh.It would have been better to work with the roon team to uncover the reason for the failed upgrade as it might lead to root cause but it seems they have their hands full.

I backed up all my /library and /applications roon directories just in case, cleaning out and reinstalling a fresh install of roonserver. I then imported a backup and I was up and running again with some loss of activity due to the date of the backup.

I have to say…my confidence in this being appliance software is very shaken.

On the positive side, I spent many hours staying up late last night listening to music again and that is what counts.

Grahame, you are a genius!

After following your instructions, Roon is now working again. Thank you so much!


1 Like

Glad you’re back listening to music but, as Paul says ( @Paul_Skillen ), this doesn’t address the real problem. It’s simply a workaround. I hope it doesn’t arise again. At least the value of a backup was reinforced for me.

Having experienced multiple issues with Roon since joining in December, thankfully I was already firmly committed to backups. Thanks again Grahame.

Hi @Jonathan_Siegel

Have things continued to work for you since your last update?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.