Roon won't transport to HQplayer

Hi there @support,

I’m having issues getting Roon and HQplayer to work together and having no luck fixing the problem. I’m trying to run HQplayer on a networked computer rather than on the Roon core machine. I’ve set it up with the correct IP address for the machine (have deleted and recreated a few times to check I didn’t have it wrong) and HQplayer works fine on it’s own outputting to a couple of different options so the problem seems to be the link between Roon and HQplayer.

The tranport / play button doesn’t seem active / isn’t something I can obviously click, it’s just a pointer which doesn’t change when hovered over. When I do click it it says"Transport: couldn’t connect to HQplayer" Do you have any ideas as to what it might be? I’ve cleared both programs in Windows firewall and looked through the knowledge base but can’t find anything that fixes the problem.

Many thanks!


Click the HQPlayer globe shaped icon to enable networking.


1 Like

Ah, I wish it was that one, I don’t have a globe icon as it’s a PC not a Mac but the allow control from a network button is already clicked, thanks though!

Is RAATServer.exe also whitelisted for the firewall ? Try disabling the firewalls on both machines briefly and check if that makes a difference.

Yes, RAATserver enabled on both and closing the firewall had no effect unfortunately…

Could it be that it’s a mixed wired / wifi network affecting it? I have folders shared between the 2 machines so seems fine there but they are both naming the network differently (1 for the wired and 1 for the wifi) which seems a little unexpected.

It the wifi device acting as a bridge or a router? In other words, is the wifi network address the same or different than the LAN address?

Hello @ElliotA,

Do you have HQPlayer installed on the core machine? I would try to connect to the remote HQPlayer instance from HQPlayer running on the core machine and try playback within HQPlayer to discern if this is a networking issue with HQPlayer or an issue with the Roon HQPlayer implementation or configuration.


The wifi is to connect the PC which is the Room core to the network, the secondary machine is connected to the router via a cable. Different addresses on both machines.

Bit of a frustrating setup but I’m renovating an apartment in the coming months and will run cables throughout for a LAN all linked to a server.

Absolutely, I do indeed, how would I go about that? I can’t get any options through the NetworkAudioAdapter and IPv6 drop downs, is it somewhere else?

Hello @ElliotA,

If you’re unable to see the remote machine from HQPlayer on the core machine, that would indicate that this is most likely a networking issue. When you mentioned that you have a mixed network, do you have multiple interfaces enabled on one of the computers at the same time?


Sorry John, it’s my lack of knowledge on terminology here but can you be more detailed on what you mean by interfaces? Are we meaning it in the sense of multiple systems working across the network? If so then I’d say Tidal and Roon are the only that come to mind but by that logic, then yes, I do.

I’ve spent a bit of time with the network this morning and have them on a homegroup now as I thought that might help, it hasn’t improved anything though unfortunately.


Hello @ElliotA,

What I meant by asking the question about “multiple interfaces” was do you have WiFi and Ethernet enabled on the computer at the same time? This can cause confusion for programs on the network because they don’t know wether to look for their companion apps on the ethernet or WiFi connection.


Ah I’m with you, thanks. But, then no, only one enabled on each machine.

I’ve been giving it a bit of thought and I’m going to be managing the network differently in a few months, taking up your time to work through an issue that will probably be fixed automatically at that point seems a bit daft /selfish. Roon itself is great and I can try again withHQplayer at that time, I appreciate everyones help with it, it’s been interesting to try and work through it!