Roon working across subnets is needed more than ever in this time of remote working and VPNs!

Roon working across subnets is needed more than ever in this time of remote working and VPNs!

It’d be amazing to see Roon updated to allow usage when on VPN, I believe the issue that the the subnet of the local machine changes upon joining a VPN, preventing Roon from functioning and in my case seeing my core, even though there is no restriction beyond the subnet change.

2 Likes

I use roon with VPN connections externally and its not an issue. Perhaps you just need to prioritise your network connections and only use VPN for external traffic.

If you can, kill the VPN, then once roon is running startup the VPN, existing connections should probably remain intact.

Thanks for the input wizardofox, for me a change in the type of VPN used with work has allowed me to get Roon working again luckily.

1 Like

It really depends on the type of VPN. If you cannot configure the VPN yourself then nothing Roon does will fix your ability to access Roon. Some VPNs allow for local traffic and some do not. If your VPN does not allow for local network traffic then the machine won’t be able to talk to Roon while on the VPN. This is commonly set within the VPN profile. Sometimes you can allow local traffic within your VPN software settings most of the time these settings are locked out. Totally in the control of your corp network though.

Ask your IT people if they can reconfigure your VPN so you can print to a local printer. That’s a much more business legit request and if they allow that then Roon may start working as well.

1 Like

Your work VPN sounds like a “full tunnel” where all of you traffic goes over the VPN.
The alternative would be a “split tunnel” where only the traffic required goes over the VPN.

The issue is that a split tunnel allows you to be connected to something else that could be malicous, while also being connected to your work network, so most work related VPN connections are quite specifically full tunnel.

HI Ian,
What VPN did you end up using? Any info would be great as I still can’t get mine to work…

Hi ipeverywhere,
when you say “Some VPNs allow for local traffic” do you mean the vpn places the device (IPhone in my case) onto the local LAN subnet?
I do that with my VPN (It’s a Vigor 2860) and I have enabled IGMP snooping as many have suggested but still no luck.
Even though:

  • I do see my iphone in the audio list and Roon is trying to enable it but never manages to
  • If I start i phone app on my Lan and then switch to VPN it works fine.

It feels so close!!! I just can’t seem to get the client app to find the Core…
I thought being on the subnet and IGMP should be enough.
Am i missing something else?
Thanks :slight_smile:

It’s a configuration of the software. I’m primarily talking about enterprise VPNs. Mose enterprises will configure the connection to make you part of the corporate network; and only the corporate network. Basically, all “local” traffic is blocked and all traffic must traverse across the VPN to the corporate network. In that case the machine isn’t local anymore it’s “living” on the other side of the VPN. In that case Roon will never work.

Other configurations only send the “interesting” traffic across the VPN and leave general Internet traffic and local traffic alone. In that case the machine sits on two network. It stays local for local and Internet but also has an “interface” in the corporate network. In this configuration Roon can work.

It sounds like your iPhone is “advertising” itself onto the local LAN so Roon sees it. But, it’s blocking the incoming connection from Roon server to configure that endpoint. Yes, you’re close, need to identify how to open connections on the local network.

  • There looks to be a “multicast via VPN” pass/block setting in your Vigor. Try both options and see if that makes a difference.

I am now using VMWare Horizon, whilst previously I was using Cisco Anyconnect and GlobalProtect.

Likely the split vs full tunnel as described by @Grumpy_Old_Man