RoonArc and VPN

Hi Guys

I have RoonCore running on my Windows10 PC with PIA VPN on. Cannot get RoonArc to successfully connect to it unless I switch off my VPN. Has anyone had any success with using a VPN with RoonArc? The trace below shows my router_external_ip as null. Is this the problem? The actual_external_ip is the address of my PC with the VPN off but is NOT the external address with the VPN on. I’ve tried manual port forwarding with the VPN on using both the actual_external_ip and the ‘cloaked’ one. No success with either. Any suggestions greatly appreciated. My router is TalkTalk SuperHub2 (UK)


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“a.b.c.d”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“e.f.g.h”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n718\nConflictInMappingEntry\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

Not sure of your error, but running VPN and ARC with no issues.

Hi…which VPN are you using and how did you configure it? Does your router external IP show up in the ARC logs?


Using Nord, but it’s not on the router at all. Just per device.

My VPN is running on the PC where RoonCore is located


HI @Paul_Moran,

Does the issue remain when the VPN is turned off?


Hi Wes

No, when the VPN is off I can connect to RoonArc without issue. I reaslise it’s a VPn problem but was posting here to see if anyone had any advice on how to configure the VPN (apart from switching it off). I have a tunnelling option on (whereby Roon bypasses the VPN when on) but still no remote access.

Thanks for any help


This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.