Roonbridge and Teralink X2

I have a Teradak Teralink X2 USB interface. It uses a Tenor TE7022 chip, which I believe runs in adaptive mode. It requires no drivers in Linux.

I have no problem using it as an output on RoonServer (with Fedora 24 distribution) , or using it on a RaspberryPi with squeezelite, but I systematically get an error message (connection to transport lost) with Roonbridge on a RaspberryPi. I have tried a number of distributions (dietpi, debian) to no avail.

Any suggestions?

Hi @anon49565150 ----- Thank you for the report and sharing this observation with us.

To help aide in my evaluation of this behavior you are reporting, could you please describe your current setup as seen here. Please also be sure to include the details of your network configuration/topology. I want to have a clear understanding of how your devices are communicating and the tools (routers, switches, extenders, repeaters, etc) being used to make those connections possible.

Looking forward to your feedback!


Roon server installed on an Intel i5 machine, with Fedora 24.
Roonbridge on a Raspberry Pi with DietPi distribution.
Both connected to network switch with fixed IP address. Network switch communicates with Internet router via cpl.
Latest versions of Roon installed.
I would like to point out that squeezelite on dietpi works fine and the issue is only with Roonbridge. It seems to me this is not a Network issue.

Hi @anon49565150 ------ Thank you for touching base and taking the time to provide the requested feedback. Both are appreciated!

Moving forward, may I kindly ask you to please reproduce this behavior, note the time when the observation is made, and send us over a set of logs so we can take a closer look at what may be going on here.

Furthermore, can you please provide the following:

  1. The make/model of the switch your are implementing.

“Network switch communicates with Internet router via cpl.”

  1. Can you provide some insight into:
  • What troubleshooting you have tried thus far?

  • When did you start noticing this behavior? Were any adjustments made to your setup before to noticing this issue? I am curious if there are any variables that could be having an influence here.


The only variable is the use of the Teralink x2 USB interface, which I was not using before… I honestly do not see how this could be a Network problem. My Raspberrypi works fine with another interface. Will send the log.

Hi @anon49565150 ---- Thank you for verifying that the Teralink x2 USB interface is the only new addition to your setup since noticing this behavior with your Roonbridge.

This is pretty basic troubleshooting as we have many users with similar configurations with no issues. For us to move forward, we need to have a complete understanding of all the variables involved and what you have tried thus far so we do not waste time offering advice/tips that you may have already tried.


How do you explain the fact that in the same network configuration using dietpi the USB interface works when running squeezelite but doess not work when running RoonBridge? The only change applied is switching between Roonbridge and squeezelite…

I believe there is some limitation using this USB interface with Roonbridge, but it is a very old model and I honestly do not think it is worth pursuing this issue… I thought maybe there would be a quick fix.
Please close the thread.