RoonBridge device not found (Solved)

I am running Roon Server on an Intel NUC.

This is on wired connection and a fixed IP address. This works perfectly for my Airplay devices, so I don’t seem to have networking issues.

I took one of my Pi’s (a version 2) and installed RoonSpeakers on it. The Pi is running Ubuntu 16.04 server edition.

Installation went fine, I verified that the service is running:

/bin/sh /opt/RoonBridge/
    \_ RoonBridge --debug --gc=sgen --server RoonBridge.exe
        \_ RoonBridgeHelper --debug --gc=sgen --server RoonBridgeHelper.exe
        \_ /opt/RoonBridge/Bridge/processreaper 1558
        \_ RAATServer --debug --gc=sgen --server RAATServer.exe

I restarted the services and had a look in syslog:

Nov 13 14:47:00 localhost systemd[1]: Stopping RoonBridge...
Nov 13 14:47:00 localhost systemd[1]: Stopped RoonBridge.
Nov 13 14:47:08 localhost systemd[1]: Started RoonBridge.
Nov 13 14:47:09 localhost[1540]: Initializing
Nov 13 14:47:09 localhost[1540]: #033[0;37;1m#033[0;0m00:00:00.022 #033[0;37;1mInfo:  Starting /opt/RoonBridge/Bridge/RoonBridgeHelper#033[0;0m
Nov 13 14:47:09 localhost[1540]: #033[0;37;1m#033[0;0m00:00:00.036 #033[0;37;1mInfo:  ConnectOrStartAndWaitForExit RAATServer#033[0;0m
Nov 13 14:47:10 localhost[1540]: Not Running (.o)
Nov 13 14:47:11 localhost[1540]: Running

So no obvious errors there either.

But I cannot see the device in the list of network devices. My airplay device is still there, and it works fine.

What are the next steps in debugging the problem?

Mystery solved.

The output devices on the Pi where not recognised by ALSA.

1 Like

Hi @Boris_Morris,

What did you do to fix the issue; load the ALSA and ffmpeg packages ?

Hi @andybob;

I didn’t actually check whether anything was registered in ALSA, busying myself with making the device appear in the audio section of the config.

Turns out that the Pi was not detecting any of its sound hardware; hacking around with the /boot/config.txt file eventually fixed that.

For my second Pi I used Raspian rather than Ubuntu 16.04 and the process was a lot smoother.

I commend you on the very quick and easily install script - I had my server up and running in about 10 minutes and the clients in the same (once I figured out the sound devices issues).

I’d like to take some credit for it :sunglasses:, but have to confess that it was all the devs. I and the other Mods and KB editors are volunteer users, not Roon staff. So we’ll treat your commendation as directed to them.

Glad you’re happily listening now. Check out Diet-Pi if you are looking at another installation. It’s a very scaled down Raspbian with a menu driven install and a low process count. There’s a thread in the Raspberry Pi section.