RoonBridge Issue [Resolved]

Helllo Team! Its been a while! Health took me down for several months… :frowning: After several major surgery’s I am back! :smiley:

Now that I am back to regular life I been having an odd issue that I cant pin point. Using Fedora 27 x86_64 iFi nanoDSD my RoonBridge plays one song and stops. I have to hit play every time or every other song…

SeLinux is disabled and there is no firewall.

Any Ideas?

No ideas per se, but welcome back…

1 Like

Thanks :smiley:

1 Like

Thanks for reaching out with your report, @Tech_Whisky_Lab.

First, I just wanted to say welcome back!

Moving forward with troubleshooting, may I kindly ask that you verify the following so we can gain some greater insight into what you’re experiencing:

  • Can you confirm that all of your devices are up to date?
  • What device is hosting RoonBridge?
  • If you use another DAC does the same behavior occur?
  • Since noticing this behavior have you tried reinstalling RoonBridge?
  • Have there been any changes to your setup since this behavior has started occurring?



@dylan Thanks for the welcome back! :slight_smile:

Can you confirm that all of your devices are up to date?

Yes they are. RoonBridge v1.0 (build 164) stable.

What device is hosting RoonBridge?

My Fedora Workstation.
OS: Fedora 27 x86_64

Intel Core i7 8700K
500GB M.2

If you use another DAC does the same behavior occur?

I have not tested. It used to work with no issues some time ago… (Maybe 6 moths ago)
You want me to try another DAC?

Since noticing this behavior have you tried reinstalling RoonBridge?


Have there been any changes to your setup since this behavior has started occurring?

Daily Upstream updates. I keep up with channel updates sense this is my Workstation.

Thanks for the info, @Tech_Whisky_Lab!

Yes, please try using a different DAC if you have one available. This will help us narrow down what may be causing the behavior you’re seeing.

I’d also like to recommend reinstalling RoonBridge and trying once more with the current DAC. Knowing if there are any changes after a reinstall will be a great data point for pinpointing this.



I am on it.

1 Like

Ok changing DAC’s did not fix the issue.
Re-installing now.

Ok. Re-install nor a new DAC made a difference.
This does not happen on any of my other systems. Same DAC.

Thanks for giving that a try, @Tech_Whisky_Lab!

Since other DACs are exhibiting the same behavior and a reinstall didn’t help, there may be some networking difficulties at play here.

Are you able to play to other endpoints from the same Core machine when they’re directly connected without RoonBridge?

Can I ask that you give a little information about your current networking setup? What networked devices are you currently using? What networking hardware is in use? How are devices on the network connected?


Everything else works just fine. As stated before my other endpoints work just fine.
My setup is quite elaborate. Let me compile that for you and ill comeback and post it.

Ok so for testing I put my old Pi on the same switch. This Pi is running an old version of RoonBridge… This is Running v1.0 (Build 141). The Pi is on the same switch as my Fedora Workstation and the Pi has no problems. It has been playing for 30Min straight with no stops.

My Sonos, Mac’s, Windows, and Squeezeboxes run with no issues.

Here my infrastructure:

Workstation OS: Fedora release 27 (Twenty Seven) Linux 4.17.6-100.fc27.x86_64 #1 SMP Wed Jul 11 20:26:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Basic information about the Server:
OS: Debian Jessie 8.6 Linux darkdreams 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux
AsRock WS Mini ITX DDR3 1600 LGA 1150 E3C226D2I
16GB Kingston Technology HyperX 16 GB Kit (2x8 GB) 1600MHz DDR3L PC3-12800 Non-ECC CL10 DIMM 1.35V Low Voltage XMP Desktop Memory KHX16LC10K2/16X
Intel® Core™ i5-4590 CPU @ 3.30GHz
Music Storage: MiniPro 1TB External eSATA 6Gb/s, USB 3.1 Portable Solid State Drive SSD
Its connected to the server via USB 3.0

Collection Size:
Roughly around 1.2K

My network:

OpenMesh AP’s: One MR1750and, Three OM5P-AC.
They connect down to my L3 Switch (Ubiquity EdgeMax) which is acting as a L2 (2 VLANS). All features are disable. The MR1750 gets PoE via the switch and the the OM5P-AC’s are bricked powered.

There is an up-link to another Two L2 Switch that connects my Server and other devices to the network. Simple L2 Netgear Switches.

All of the devices get lease via DHCP from a pfSense Firewall.

Let me know if you want me to update the roonbridge on the Pi.

Also I for got to note. My Workstation does have a bridge. I have KVM running with several VM’s. But I cant see where roonbridge would care if its a bridge or not…

Thanks for the detailed setup information @Tech_Whisky_Lab!

Interesting that the Pi works here. Yes, let’s try updating to the latest version and confirm it still works. If possible, use the exact same Ethernet connection as the other RoonBridge. Knowing whether or not this device works with the exact same version and connection will be a great data point.


Ok. Done. Will report back.

Been running for about 30Min with no issues. So we know that is not the ethernet port nor the cable. And we also know that is not the RoonBridge version.

Ideas? :slight_smile:

Thanks @Tech_Whisky_Lab!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more with the device that is not working and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


1 Like

It just happened. 3:53PM CST

@dylan I might have found something. I think the system is fighting for the output… :confused:

Yup, That was the problem. The system was fighting for the default output making RoonBridge get disconnected. Fixed by setting my asound.conf global directives.

Seem to be be a known problem when using yuky pulse :face_vomiting:

All fixed!

1 Like