Roonbridge not being detected

I’ve read all the other posts on this problem. I will say that this WAS working but at some point the PI4 did an update of Ropieee XL and I lost the PI being detected in SETTINGS: AUDIO via Roon. No changes to networking environment. Shairport shows up fine. And when I got to SETTINGS: About I see the Roonbridge for this PI as being listed with correct IP address. I also see this same IP in my router view. And I have another PI4 running same version of Ropieee on same network that is detected and works just fine. Have rebooted Roon Core, PI4 several times. Even reinstalled Ropieee and set up again. Still not detected. Have USB DAC - Topping D90 - which is on and connected. Very frustrating stuff. Any suggestions?

Update: the one thing I hadn’t done was reboot the switch that the PI4 is networked through. When I rebooted that my working PI4 disappeared as expected and when the switch came back up that same PI4 came right back up to SETTINGS: AUDIO in Roon. But the problem PI4 is STILL NOT DETECTED. I’m out of ideas. Need help here from someone and/or @spockfish

Restart the dac and maybe try a different usb cable or at least reconnect it

Check the dac is powered on too or you won’t see in audio zones. Check the usb setting is correct on the dac too

Can you send feedback? You can find that on the ‘advanced’ tab.

This is a config that has worked prior with same DAC, same cable, same everything. The only change is the new Ropieee auto update that must have happened while I was on vacation. I’ve restarted everything, powered it on and off, rebooted etc. etc. No changes to DAC config: USB–>XLR output to my amp.

Yes, will send the feedback within the next hour. Thanks for looking into this.

@spockfish Just sent the feedback. ID: 07c43bf5dad0d9bb

Thank you!

-Michael

There was an issue with my infrastructure. Can you sent it again?

Done. Here’s the new ID: 8998f81917eef95f

The DAC is simply not recognized. Or, to be precice: it is not plugged in. Hence no audio device and no show up in Roon.

That’s extremely weird. DAC is plugged in and on. USB cable is same one that came with Topping D90 and that has worked in the past. The one last thing I hadn’t done was to literally power off the DAC using the power switch on the DAC instead of the remote’s power switch. Why would that make a difference? So just now I unplugged the DAC cable USB B side and A side, powered off the DAC using the on/off switch on the DAC, and moved the A side of the cable to a different port on the PI4. Powered the DAC back on. And now, after all that, I see the D90 in Roon as available to ‘Enable’. Why any of that made a difference is beyond me but sharing this here in case anyone else runs into same issue. Don’t use your DACs remote to power on and off! Thanks @spockfish.

I will add though that Roon was showing the RoonBridge on this PI correctly in SETTINGS: ABOUT. Just not in AUDIO. I guess the DAC USB connection not being recognized is the answer for that.

Sometimes dac usb interfaces get locked up and powering the dac off doesn’t always work as many also take power from the usb side hence my post earlier to unplug it and restart the dac

Yeah, I think you were correct on this. I thought I was doing what you were suggesting by using the DAC remote to turn it off and then on. But yes, a hard power off was likely required. Lesson learned. Thanks again.

1 Like