RoonBridge Not Discovering Devialet at startup [Solved-ish]

When I reboot my machine with only Roonbridge installed, I have to remote into it quit Roonbridge and start it again for it to appear to my server and remotes.

Anyone else seeing this?

No. What is it running on?

Windows 10, i7 3770, 8GB, Intel SSD. OS has every non-required feature turned off and all this machine does is host Roonbridge.

When it’s booted, can you see whether RoonBridge is running?

As I said in my initial post I have to RDP into the machine which will auto login on reboot, quit Roonbridge and restart it to get it to work.

Ok, just wanted to make sure it’s actually starting and not failing during the startup process. I’m not a Windows guy but my experience running pre Linux Roon on 2012 R2 tells me it may be something to do with the sequence or user under which Roon is being launched on boot. I’d look at whether networking is up by the time Roon’s launched during the startup sequence. Beyond that best you have @vova look into it.

That’s interesting…it means that part of our discovery stuff isn’t working on your network. Your core is seeing RoonBridge when it announces itself, but not able to do a query/response with RoonBridge to discover it when the core comes up later.

@brian The core wasn’t rebooted, it’s on my server and was always running. A separate dedicated machine with just RoonBridge is where the issue lies.

When I restart it, I see it disappear in my RoonRemote. It never returns though. I have to RDP into that machine and quit Roonbridge which is running and start it again. Only then does it reappear in my RoonRemote.

Ah ok…hm.

I usually start troubleshooting stuff like this by simplifying: disable all firewalls, restart the apps and look for improvement. If it’s better, start turning them on one by one. Once you’ve isolated which one is implicated, there are sometimes settings to dig into.

If you’re already firewall-free, then we would look elsewhere…

The firewalls are disabled on all my machines inside my firewall. :grin:

I could turn the auto login off and try it once that way. That would allow enough services and the network to be all hunky dory before I log in and RoonBridge starts?

If you can figure out a way to modulate the problem, it will definitely point us in a direction.

1.2 relies on networking stuff working right a bit more than 1.1, even though it uses a lot of the same infrastructure for discovery. I bet we still have one or two quirks to work out.

Ok, I can say it’s 100% related to not having any audio devices available on the machine when RoonBridge initially starts up.

I’m messing around with Devialet AIR which is of course a virtual sound device that starts on system start up as well. If I shut down AIR and start RoonBridge, it doesn’t show in my Remote. If I start AIR after RoonBridge is running it still doesn’t show on my Remote. I have to start AIR first so their is a sound device and then start RoonBridge.

I hope that’s all the information you need. I don’t expect a fix, I’ve just come to accept these things when it comes to the Devialet.


It’s something I can deal with on reboot, I’ll just log in and manually start them in the right order.

I could see that happening, particularly if the device appears to exist from our perspective, but isn’t ready to be spoken to yet.

If you don’t mind, I’d like to have a look at the RAATServer logs from your roonbridge machine–it’ll be in C:\Users\USER\AppData\Local\RAATServer\Logs. Maybe there’s something obvious there that we can work around without too much trouble.

This is probably something you could script with a little batch file. Instead of setting RoonBridge to run at boot, make a tiny batch file that waits 20s and then runs RoonBridge.exe and add it to StartUp. A little bit more work, but at least you won’t be mucking around every time the power goes out…

Ok, now I’m confused. I enabled Devialet AIR in Roon again and repeated the starting of RoonBridge before Devialet AIR was started and it showed up on my RoonRemote.

We do make an effort to figure out when devices appear/disappear–but some of these software things don’t behave quite as crisply as actual devices. It’s possible that there’s a timing thing that doesn’t fail every time, but fails sometimes. Thanks for the logs.

This is also happening to me with my Ayre QB-9 and headless NUC. When I reboot the NUC (with RoonBridge set for auto startup), it doesn’t show up again in any Roon control point until I RDP in and quit, restart RoonBridge. It does seem like there’s some problem with the order in which RoonBridge is started during bootup.

I just found an easy fix. Put the RoonBridge shortcut in the Windows startup folder, disable “Launch at Startup” and voila.

Are you using an ASIO driver with your QB-9?

Yes, I am.