Roonbridges disappear and creates multicast issues with Hue on network

Core Machine (Operating system/System info/Roon build number)

Lenovo ThinkCentre M92P 2.9GHz Core i5 6GB RAM 128GB SSD Windows 10 Computer running Roon 1.6 (401) 64 bit.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All Roonbridge devices are connected via Gigabit Ethernet via an unmanaged TP-Link switch to a TP Link Archer C7v2 Router. The Roon Core is connected directly to the Archer C7v2 router via Gigabit Ethernet cable. There are no VLANs and the network is flat.

An LG file server containing approximately 2000 MP3 and FLAC files is connected via gig-Ethernet to the TP Link switch and is accessible to Roon as my personal content library.

The Hue bridge is also connected via Ethernet to the TP Link switch and is in the same network subnet as the Roon devices.

An android Asus tablet running the Roon application controls the content. The same tablet runs the Hue lighting application and the Harmony Hub application to control the main AV system connected to the RoonCore in the living room.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

The Roon Core runs on a Windows 10 Lenovo M92P connected via HDMI (WASAPI) to an Oppo Blu-Ray player that in turn connects via SPDIF to a DEQX PDC 2.6p.

RoonBridge 1 runs on a Linux Mint 19 loaded onto Z83-F Mini PC with 4GB RAM, 64GB Intel Quad Core CPU 1.92GHz. RoonBridge 1 is connected via Gigabit Ethernet to the TP Link switch. The HDMI output of the Roonbridge is connected to a Polk Audio Command bar.

RoonBridge 2 runs on a Linux Lubuntu loaded onto Intel Baytrail-T (Quad-core) Z3735F 1.83GHz, 2GB RAM+32GB storage. RoonBridge 2 is connected via Gigabit Ethernet to the TP Link switch. The HDMI output of RoonBridge 2 is connected to a Pioneer AV receiver.

Description Of Issue

I suspect an issue with RAAT and multicast here based upon some basic troubleshooting and my experience in building large complex networks. This network is very simple, however. All Roon devices are connected via Ethernet and are assigned to the same private subnet.

I have run this same RoonCore machine for several years (pre 1.3) without issue. The RoonCore has been able to play files from an LG NAS and from Tidal with no hiccups in playback. Roon is controlled by an android tablet running the Roon application.

On this network I also have a Hue bridge that controls around 30 Hue lights. The Hue application also runs on the Asus tablet and lights are also triggered by several Amazon echo devices. Over the past couple of years this has all coexisted nicely.

Recently I got the brilliant idea of re-purposing a couple of micro PCs to stream my music collection to the master bedroom and another stereo system in an office. The details of the PCs and the Linux loads used are listed above. And this is when the fun (troubles) began.

Once the RoonBridges were created and added to the network I was able to configure both using the Roon interface from the tablet. There appears to be plenty of memory and processing power to allow both to run some upsampling (RoonBridge 1 is limited to 24 bit and 96Khz, RoonBridge 2 to 32 bit and 192khz) and headroom management. When either unit is freshly booted it is found by the RoonCore and one can choose to group audio one bridge plus the core or to stream individual programming. This works for audio from the fileserver or from Tidal for a little while. Within an hour or so playback will begin skipping or will stop completely to the RoonBridges with the warning error in Roon that there’s a network or hardware issue. Also the RoonBridges will begin disappearing in the application interface as a zone. If the afflicted Bridge is rebooted it will appear again and one can begin using it for a short while until the same error repeats.

At this same time when either Bridge is connected to the network the Roon app will often behave in a sluggish manner, often searching for the RoonCore for several seconds.

Once the RoonBridges begin to act up the RoonCore has difficulty playing music from the LG NAS but Tidal remains mostly unaffected. Files from the NAS may play on the Core for a few seconds of minutes before dropping and then skipping to the next file. A good indication of network congestion on the private network.

Now here’s another interesting part to this. Once I brought the RoonBridges onto the network, my Hue lights started acting up. When I would tell Alexa to trigger a certain light or group of lights I would often be told that Hue was not responding and to check the power or network connections. When using the Hue application it would often take several minutes for the application to find the Hue bridge and display the status of the lights and if I tried to turn lights on or off, etc, it was hit-or-miss if the light would respond correctly. Often the app would lose connection to the Hue bridge and have to reestablish communication.

I suspected that there is a conflict between Hue and Roon running multicast discovery so disconnected the Hue bridge to try to narrow down the issue. This had no effect on the stability of the RoonBridges. The RoonBridges would continue to have failure in playback and then disappear from the zones in a predictable manner.

I then removed RoonBridge1 and then also removed RoonBridge2. With both removed the RoonCore playback from the NAS or from Tidal is flawless again and the application readily finds the Core and asserts control.

Once I added the Hue bridge back onto the network the lights worked properly and there was no perceived detrimental affect to Roon.

Upon doing a little reading on the web it seems Roon creates some conflict with Hue in the way it runs discovery over multicast.

I look forward to your feedback. Please share your thoughts and suggestions for troubleshooting and a proper diagnosis.

Best regards,

John

I had a hue hub on the same network as my Roon system for 2 years and never had any trouble with discovery. Are you sure your router or switch is not causing this issue have your tried changing any settings that refer to multicast ?

Hi @John_Wilkinson,

I have a very similar setup to yours, TP-LinkAC1750, Phillips Hue, Multiple Endpoints, Harmony Hub, ect. but I can’t say I’ve seen this issue occur. I have a few thoughts here:

  • Can you check to see if IGMP Proxying/Snooping on the router trigger any change in behavior? I’ve sometimes seen the need to enable this setting on a few routers and would be worth a try.

  • If you connect the Roon Bridge devices directly to the router as a test and temporarily bypass the switch, do you still experience the same issue?

  • Are you using the latest firmware version from TP-Link for the router? Or are you perhaps running a custom router firmware?

  • Have you made sure to add both Roon.exe and RAATServer.exe to the Windows Firewall and also to any Antivirus firewalls you may have? You can use these instructions to check the Windows firewall and Roon.exe and RAATServer.exe can be found in the Database Location/Applications folder. I would set it to both public and private networks.

Please let me know if any of my above suggestions help.

Thanks,
Noris

I have had Hue and RoonBridges deployed for years with no negative interaction.

Great tips, fellow Roonies. I’ll go double check on the firewall settings. IGMP snooping is not an option on the Archer C7 and I am running its latest firmware. The only Multicast options in this router are to bridge a LAN port for the use of IPTV or to tag a port with a VLAN if engaging the IGMP proxy, presumably also for IPTV services. I have previously engaged the IGMP proxy but that had no noticeable effect on the behavior.

Edit: Firewall double-checked and Raatserver and Roon are allowed on both public and private.

@noris I won’t have time to move the RoonBridges to the room in which the router resides until the weekend to double check that the switch itself isn’t at fault but I will check that for sanity if nothing else solves in the meantime.

Thank you all for the suggestions.

1 Like

Maybe you want to check your switch?
There are switches out there, also from TP-Link, that have IGMP snooping buit-in.

I’m going to install wireshark on the Windows Roon Core and see what’s happening on the NIC. Stay tuned.

1 Like

John, Do you have any update, what did Wireshark report?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.