Roonlabs and Tidal service stopped working


It looks like technical issues with Tidal integration w/Roon services as of this morning.

Please post more information on an estimate as to when this service will resume.

Thank you

1 Like

Roon & Tidal working in Memphis TN now. Probably best to reboot your Roon core and if that does not solve the problem post in the Support forum.


1 Like

I am having bizarre issues as well, I do have tidal, but my Bridge no longer is recognized by my core as of this morning. :frowning:

Bridge: Pi 4 / Ubuntu 19.10
Core: AMD / Ubuntu 20.04

I’ve had roughly the same problem this afternoon when Tidal suddenly disappear… then I restarted the ROCK without success, this the result was I was not registered, doing the new login result in Roon trying to connect without success (the circle rotating endless)

What was that. ? Wha was broken… the service from to their customers o the connection between Tidal and Roon?
Tidal on my mobilie was working perfectly

I was just able to re-establish connectivity with Tidal.

Basically had to log out and back in again.

Tidal was working fine when accessing it directly.

Looks like something broke and it got mysteriously “fixed”

I had no issue today and listened most of the afternoon.

1 Like

I’ve tried this as well, but I’m still getting that eternal ‘attempting login’. Anyone else still having issues getting connected with Tidal. BTW, no problems gettting into Tidal directly. Thx

I’ve had repeated problems with TIDAL and Roon as well, ever since the new ‘oauth’ TIDAL login system was implemented. I’ve been able to resolve it each time, so I haven’t reached out to @support before, but it seems this has become chronic (though still not all that frequent)…

Today, I just updated my MacBook Pro from 10.15.3 to 10.15.4 – the MacBook is only acting as a Roon remote – it connects to a Nucleus in another room running the latest software (v1.7, build 528). After updating my Mac, the Roon overview screen would not display anything except for the moving icon in the center of the screen (I left it for a few minutes, and also quit and re-opened Roon with no change), though Genres, Discover, and Qobuz screens all displayed normally. Of course, the TIDAL-only page would not display at all, and in Settings: Services, I saw the spinning icon next to the TIDAL ‘Edit’ button.

I attempted disabling and re-enabling the TIDAL account there as a quick fix, but it would never re-enable, so I logged-out of TIDAL. As you know, logging back in to TIDAL now involves multiple steps including a number of CAPTCHA pages which I find incredibly annoying. At some point TIDAL must have decided that I’d jumped through enough hoops, and finally allowed me to successfully complete the login.

If this were only a once or twice a year problem it wouldn’t be a big deal. I haven’t been logging this, but believe it has been four times now – just in the short amount of time since these recent changes.

I understand that Roon may not have much recourse if the new login headaches are a requirement that TIDAL has mandated, but perhaps by mentioning it here instead of just silently ‘fixing’ the problem each time, some progress towards a solution could be made (Roon working with TIDAL).

Personally, I’d rather have a 2FA (Google Auth or similar) login requirement vs. the current web login with the silly CAPTCHA screens nonsense, if it were deemed truly necessary at all. Also, it would be nice if the Roon (macOS remote) app’s overview screen still displayed – just without the TIDAL content, instead of coming up completely blank just because TIDAL isn’t ‘playing nice’ with Roon.

I still love Roon, just not feeling the love for TIDAL’s new login / repeated AUTH issues. Thanks.

I just had some issue playing Tidal as well that was fixed by restarting Roon. IMHO Roon takes waaaaaay too long to load.

1 Like

I second your thoughts exactly Sonny.
Our modern lives are filled with enough login headaches. I’m sad that my previously flawless music playback system (NUC) is now just another pain in the ass.

1 Like

Similar trouble for me too around 9pm UK time on Friday. Had to log out of tidal then back in again this morning to fix it. Tried to first disable Tidal but that just caused the whirling circle. Couldn’t even get to Overview screen ( Roon jellyfish, presumably because there was a Tidal CD displaying on it?) but Roon could play music from my library from other views. It seemed to lock up one of my Pi endpoints too.
Could really do with a Tidal switch in the profile set up so I can easily disable the damn thing by switching profiles when it is playing up and taking the rest of the Roon app down with it.

Since removing/uninstalling ROON Bridge from my host, I am no longer experiencing this issue.

Okay I lied. The issue is back again.

looks like todays update has fixed this issue time will tell


Roon/Tidal issue fixed for me, however we should continue to monitor!

One more update from Roon calling out Tidal fix:

I have the same Issues. Since maybe 14 days no longer reliable Tidal login. Stuck in Login Loop ore get incomplete tidal playlist. Same play with qobuz. I pay a lot of money sice 3 years for this resolve this or i am no longer a costumer. In audirvana works Tidal an Qobuz very fine on the same dive same network! Resolve this!

Hi Marco, that issue has gone away for me including many users who’s had this behaviour - if you’re still seeing an issue, contact the technical support team, cheers!