RoonRemote cannot connect to library properly since yesterday[Solved]

Hi guys,

I am using RoonServer since 2 weeks and since yesterday I am experiencing problems when trying to connect with the library.

My setup is as follows:

  • RoonServer 1.1 (build 102) running on Win10 NUC with 16GB RAM and i3 CPU
  • RoonRemote on Nexus 9 Tablet

When I wake up the NUC from sleep mode, RoonRemote does not seem to be able to connect with RoonServer, it just says “initializing…”.

What can be the problem?

In my case a restart or restarting RoonServer helped, which might also only be a coincidence.

Any advice would be appreciated

Hello @Kian_Pariwar,

Apologies for troubles. Have you tried to restart Roon server and reboot your machines?
Can you also describe your network setup? At first sight it looks like a network glitch.



as I wrote above restarting RoonServer helped, but this is no viable solutio IMO, as it is inconvenient, given that I am using the NUC for Kodi while letting run RoonServer in the background.

My network setup is as follows:

  • Cable Router connected to WiFi Router via Ethernet Cable
  • NUC connected with Wifi Router via Ethernet Cable

Somehow, restarting roonserver also does not work.

How many seconds do I have wait until roonserver is really running again?

When I close roonserver on the win10 machine my Nexus 9 immediately recognizes it and changes the status to “connecting”. When I run roonserver my Nexus 9 also immediately recognizes it and switches to “initializing” but stays in this status.

What can be going on?

Hey @Kian_Pariwar,

Loading time of RoonServer completely depends on the library size, but it shouldn’t be more than 2-3 minutes. Let’s clarify the details

What are the IP’s of the Server machine and the tablet?
Are they connected to the same Wi-Fi router?
Do you user DHCP or fixed IP’s?
Do you use a bridge mode for your Wi-Fi router?
Is the firewall enabled on either device (including the one which is built-in Windows)?

IP of Server (NUC):
IP of Tablet:
DHCP is used
No bridge mode activated
FW enabled on Router and Win10. Tablet, i do not know, is there a FW for tablets?

I checked the Win firewall and all roon services are not blocked, i.e. they are marked as “allowed”.

nevermind. human error, as always. I missed one roon firewall setting which was blocked from public access. now everything is working as it should be.

still weird though:
what is roon doing after I wake up roon from sleep state? Somehow it communicates with the internet, i guess it is the membership check…

Thanks for info @Kian_Pariwar. I’ll mark this as solved.

This topic was automatically closed after 24 hours. New replies are no longer allowed.