RoonRemote on Android Tablet is missing letters

Hi guys,

I observed a strange behaviour of my RoonRemote on my Nexus 9 Android tablet:

As you can see in the screenshot above the roonremote interface is missing letters. I can get rid of it once I restart the roon app on my tablet.

Any idea why this is happening or how it can be solved? you can ignore the error message below, somehow the internet connection is not stable at the moment

I would check to see if you have a number of apps running (and if so close them). If that doesn’t work restart the Nexus 9 and see what happens.


restarting the nexus 9 is not necessary. just restarting the roon app does suffice to fix it. also, there are no apps running in the background. at most, the chrome browser might be running when i decide to browse the web. but usually i am using the nexus 9 exclusively for roon.

the behaviour in the screenshot above only happens randomly when i turn on the nexus 9 screen for controlling roon. if it helps: i am running roonserver on my nuc

Kian, just a quick question. Are you leaving the Roon app running and turning the screen off and then when you turn the screen back on the disappearing letters occur?

good question i cannot say for sure as this is a random behaviour. I will test and let you know.

I have this on a Sony Xperia Z3 android phone.

Try and close some apps and restart Roon. This has been reported a couple of times


That is not a fix.

Youre phone has a limited amount of resource. What’s your preferred fix?

Same problem here, missing characters. Restarting Roon helps, but problem isn’t solved with that. My remote is a Oneplus One on Android 6.0.1.

Edit: language

Did you check to see if you had many apps running at the same time? My experience has been close apps and then restart Roon i.e. it has always seemed to be a resource issue.


Interesting, although characters shouldn’t be missing ‘just’ because of that. Normally I don’t have that many apps running. However, I’ll keep an eye open for that.



Yes - I’ve been thinking about this today and don’t know if any Apple users have had this problem with their iPhones and iPads.


Any solution in the works? My Pixel C is having the same problem … annoying…:unamused:

By any chance do you have your fonts set to anything other than the default setting. I’ve seen this happen when the default font size has been changed, either larger or smaller.

Hi @Rugby,
No, I haven’t touched the fonts, they’re still on default setting.

If the Roon app is in the background for some time, characters start disappearing. It doesn’t stop with that, as this screenshot shows. Except for more characters disappearing with time, other parts of the screen disappear or just the opposite, they stay in place, while others are placed on top of them and the whole screen is a jumble… In this case on my Pixel C…

My Pixel C has this kind of issues as well.

Some time back I had a strange flickering screen, I was able to grab a screenshot:

@support, can this be some kind op OpenGL issue?

…Another one, this time the screen is scrambled with all kinds of icons:

Hi @Bluebeat —— Thank you for the report. Unfortunately, this looks like a performance issue, meaning that Roon needs a certain amount of video memory to run but for some reason your device is running low, which is causing issues as the interface is rendered.

In most cases, this means too many things are running at once, or something is using an inordinate amount of memory. Does this persist when you restart Roon? What if you quit other applications first? What about after a reboot of the device?

We’re always looking for ways to improve Roon’s performance and we may be able to make this better in the future. For now, we’ve found that in most cases these issues tend to come down to a device (usually in a temporary state) on which the required graphics memory is simply not available. Let me know how you do with the tests above and we can look into this further if you’re seeing this consistently.