RoonServer crashing on a few Synology devices [Solved]

While building the installation package for x64 Synology devices most users reported that it worked flawlessly. But there are 2-3 users that experience a crash of RoonServer on startup (and this crash runs in a loop then…).

When connecting via ssh and perform the script. Everything is “ok”. After running the script the following error message is displayed.

Not responding

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Sooloos.IPAddresses.unix_get_ips_with_netmasks (intptr) <IL 0x00011, 0xffffffff>
  at Sooloos.IPAddresses.GetAll () [0x00011] in /home/roon/roon/RoonBase/netinfo.cs:326
  at Sooloos.SOOD.Connection.FixInterfaces () [0x00000] in /home/roon/roon/RoonBase/sood.cs:442
  at Sooloos.SOOD.Connection.<InitSocket>m__3 (object) [0x00027] in /home/roon/roon/RoonBase/sood.cs:348
  at ThreadUtil._DoWorkItem (ThreadUtil/_WorkItem) [0x00000] in /home/roon/roon/Base/threadutils.cs:270
  at ThreadUtil._WorkerThread () [0x0008c] in /home/roon/roon/Base/threadutils.cs:260
  at System.Threading.ThreadHelper.ThreadStart_Context (object) <IL 0x00022, 0x00083>
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) <IL 0x00083, 0x001f1>
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) <IL 0x00004, 0x00023>
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object) <IL 0x00031, 0x0005b>
  at System.Threading.ThreadHelper.ThreadStart () <IL 0x00017, 0x0002f>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x00056, 0xffffffff>

Native stacktrace:

        /volume1/@appstore/RoonServer/RoonServer/Mono/bin/RoonAppliance() [0x4ed10e]
        /volume1/@appstore/RoonServer/RoonServer/Mono/bin/RoonAppliance() [0x41993e]
        /lib/ [0x7f7bb99031c0]
        /volume1/@appstore/RoonServer/RoonServer/Appliance/ [0x7f7bb50c0ffa]

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

It is hard for me to find out what the cause of this error is. I could test it only on my own devices (DS1511+, DS716+), but have not the whole product palette of Synology devices to investigate. From the specs. of the devices, that output this error it should actually work (DS2413+, DS1813+, DS412+)

I tried to find out what kind of devices are affected in this topic:

All of the users with this issue had a device with an Atom D2700 CPU (but the DS713+ with the same cpu could install and use it). So I am not sure if this is cpu related.

The installer package for Synology does not touch any files from the RoonServer installation.

Thanks Christopher,

Let’s drop a flag for @brian.

Thanks @andybob. @crieke and I have been going back and forth offline…we’ve made some progress.

I am one of the users who has not had an issue ( well one, but that was related to a particular RoonServer build for Linux (“corrupt build”) that caused RoonServer not to work, since fixed )

Mine is an 1812+ with 3GB RAM, Intel Atom D2700 CPU - Dual Core.

Build 142 solved this issue.

1 Like