RoonServer not working with new NAS - only getting Roon busy display

Core Machine (Operating system/System info/Roon build number)

Win10 Home(latest updates)/i7-6700k/Roon V1.6 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Arris BGW210-700 router/switch(4 ports) - RoonCore connected to this - Netgear RS426 NAS also connected to Arris

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Waversa DAC3 MK2 connected to Arris via ethernet

Description Of Issue

Setup Roonserver share to NAS - music is imported. Rooncore keeps cycling between connected and initialize and I’m not able to connect. Long story short - if I disconnect the NAS or disable the network card on the PC, Roon will come up but with no music showing - if I enable the Esata storage it will read in the music fine. If I disable the Esata and reconnect the NAS, Roon will start reading music but stop after 50000-60000 tracks and just show the busy icon in the center of the screen. I’ve updated the Realtek Pcie GBe drivers but that made no difference. Everything was working fine the other day. Since the library is big(34000k albums and 400000k+ tracks) it takes a long time and is very frustrating. :wink:

Thank you.

? No clues?

Hi @Tony_D_Angelo,

Can you enable the NAS once more and make a note of the time RoonServer starts experiencing issues? Once you’ve done this, I was hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link.

Respond here with the time and the dropbox link and we will take a look.


Hi Dylan, I will send the logs after work. Last night I tried a usb3 to Gig ethernet adapter to connect the core to my router/switch and eventually the core came up after it finished looking at my library on ESATA. I then connected the NAS (Roon share disabled) and the core stayed up. I also have a Waversa WCore and it experiences the same issue with the NAS connected.Thanks for the reply.


Hi Dylan, the Core worked when I tried it today on my PC with the NAS connected. Nothing changed from yesterday on my system - weird.

On my Waversa Wcore I’m still not able to connect with the NAS connected. When I pic the Wcore it starts to connect and I get the busy icon for about 5 minutes and then I get the Roon display. If I try to add a network share using \nas\roon it thinks about it for a bit and then disconnects - eventually it shows ready - I try to connect and it goes back to initializing or just the busy screen. I attached some pics and sent the Roon log - I’m not able to get to the WCore logs as it’s a closed system and I don’t have access.

here is the drop box link



so, spoke too soon. When my PC core finished importing music from the NAS it went busy and finally I disconnected the NAS to shutdown. Here are the logs:

Thanks, @Tony_D_Angelo — I’ve passed the logs along to the team for feedback, I’ll follow up once I’ve heard from them.

Hi @Tony_D_Angelo,

Can you confirm some additional details about your Core machine? How much RAM does it have? How much free storage space is left on the drive where the Roon database is located?

When you’re experiencing these issues, what is memory usage looking like?

16gb - 4gb in use when it just CRASHED after several hours of importing from the NAS. The database SSD has 112gb unused. This is getting really old… Have diagnostics been enabled yet? It seems only the squeaky wheel gets any answers.

Thanks for the info here, @Tony_D_Angelo.

I’ve updated your ticket in our system and the technical team is continuing to investigate. As soon as I have further feedback from the team I’ll be sure to reach out.

thanks. My machine is on now if you have remote diagnostics turned on. 3PM Eastern time.

I keep seeing this in the log when I’m seeing the busy icon.

Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)

@dylan any update?


Hi @Tony_D_Angelo,

I spoke with the team today about our next steps here and I wanted to follow up with you. We are hoping that you can try importing a smaller subset of the media from the NAS — roughly half if possible — so we can determine if there’s any change when there is less media in use in Roon. Can you give this a try and let us know how it goes?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.