RoonServer Stuck Initializing on new Mac Installation, Logs Showing Critical Exception [Fixed with build 987]

Yes there is and a fix is being worked on

Good to know the problem is not on my side. Roon all-in-one app works fine.


I can confirm that the full Roon all-in-one download is working on my MBP as well. Thanks for the tip, @Ales_Micka!

Well, except my Playlists which have the same issue that I’ve been having for months when trying to migrate from my NAS to a MBP. :frowning:

Hi All,

Experiencing the same issue as well, brand new install of Roon Server - just rebuilt my Mac i5 2012.

Would be good to understand where the ticket is at for the fix. I’ll install the Roon all in one app in the interim.



As with most bug fixes it’s probably in testing and unlikely to be pushed for public release until the weekend is over and support is fully on shift again for weekdays.

I’m currently experiencing this and can’t seem to figure out how to get it solved. I’ve rebooted my Roon Servier Mac Mini and whether trying to run the client on my iPad or directly on the Roon Server, I’m in an endless “initializing” status. Version 1.8 build 970.

I have no clue where to start with troubleshooting. Network is fully in tact. Not changes at all to my router. Full access to the internet.

I’m experiencing the same issue on my Mac Mini 2014 that I had been using as my RoonServer for years.

I recently got a M1 Mac Mini to replace it and forgot to back up my old server prior to installing RoonServer on the new Mac Mini.
When trying to go back to my old server to do the backup, I’m getting the same “Initializing…” error.

Both Mac Minis are running Version 1.8 build 970.
The M1 Mac Mini starts just fine, but the old one is now stuck.

I tried installing the full Roon on the old mini, to no avail.

Is there a way I can access the cache/backup of the old Mini despite the startup issue?

Edit: as I was typing this, the old Mini finally showed “Connect”.
However, when I click on it, I’m getting the login page and quickly after that an error message shows up saying that the Core wasn’t connected. I can’t do anything on this Core.

Edit 2: I’m getting the same error on the new Core now…

Changing from Roon Server to Roon (or vice versa) necessitates renaming of the Roon (or Roon Server folder) in the Library.

Locate the folder following this method:

Then try this method:

Hey everyone,

We cannot thank you enough for your continued patience as we navigate this issue. Not being able to access and connect to your core is immensely frustrating and I completely understand the gravity of this bug. I also wanted to thank everyone again for providing detailed reports of the issue.

I have a good update to share: we have discovered a solution to this issue, and are on the final stretch to getting it released to you all. I can’t comment on a specific timeline, but we are without a doubt on the home stretch.

In the meantime, if you’d like, you can download the Roon-all in one app which should connect normally. Let me know if you have any questions, and I will follow up soon with more updates :pray:

Hi Benjamin, what is this all-in-one app you speak of? I don’t see mention of it on Downloads – Roon Labs

The basic Roon app, as I’ve circled in red, is also known as all in one, because it is in essence a roonserver and client in one package. However, it can also just be a client if you have another core alredy on the network, when you install it, just connect to that core and the server portion won’t be activated on the PC.

1 Like

Thanks Rugby, makes sense. However, Benjamin said this:

I do have the Roon app on a Macbook Pro, and it can’t connect to my Roon Server running on a separate Mac Mini (probably due to this bug). Do I not understand what @benjamin was suggesting?

@Matt_Armstrong I think @benjamin means connect locally. So rather than install RoonServer on your Mini you would install the full Roon package on your mac Mini (probably the same one you installed on your MBP), and during initial setup you would choose the option that’s labeled something like “Setup this device as your RoonCore” (sorry, don’t remember the verbiage). Another way to think about it is you would install the same Roon dmg (circled above) on both your Mini and your MBP, but on the Mini you would set it up as the Core and on the MBP you would use it to connect to the Core. Hope that helps.

1 Like

Roon Core Machine

RoonServer v1.8 (build 970) stable on macosx
macOS Catalina 10.5.7
Mac mini (Late 2012)
2.3 GHz Quad-Core Intel Core i7
4 GB 1600 MHz DDR3

Networking Gear & Setup Details

A number of Google Wifi mesh devices. The Mac Mini is plugged into one of them by Ethernet. I’m able to connect to the Mac Mini with remote desktop.

Connected Audio Devices

n/a, as I can’t connect to the core at all

Number of Tracks in Library

Maybe 2-4K tracks?

Description of Issue

I upgraded the core and updated macOS at the same time. After this I can’t connect to the core. All my Roon remotes say that the core is “initializing”. It has been like this for a few days – I can’t precisely remember, as I left it for a while hoping it would fix itself.

I have uploaded a “Matt Armstrong” to the Roon logs upload server as described here

If we move to use the full Roon in the meantime, is there an easy way to transfer the database from the RoonServer to Roon in the library?

I just need my RoonServer to start so I can export its database and migrate it to my new Mac mini (which is running the full Roon, actually).

1 Like

So, a workaround for the problem where Roon Server fails to fully initialize and function is to run Roon instead of Roon Server. However, there is a problem: the two programs look for their database in different places. Here is how I addressed this problem on my Mac Mini:

  1. Consider that I am a casual user of Roon, and this is not a recommendation coming from Roon support! :slight_smile:
  2. Log in as the user running Roon Server.
  3. Quit Roon Server. No program from Roon should be running!
  4. Open a Finder window and show the home folder.
  5. Configure Finder to show the Library folder. (View → Show View Options and check “Show Library Folder”. Note: don’t mess around in the Library folder casually, it is hidden by default for a reason.
  6. In the Library folder Ctrl-Click (or Right Click) on the RoonServer folder (within the now visible Library folder) and duplicate it.
  7. Rename the new “RoonServer copy” folder to “Roon”. This is the folder the “Roon” app will use.
  8. Rename “RoonServer” to “RoonServer OLD” (or move it to the Trash).
  9. Download “Roon” from, install it, and run it.
  10. Log in. It found all my local music, was able to play it, etc.
  11. When you’re comfortable with this solution, move “RoonServer OLD” to the Trash.

Hope this helps!

Tried it, it says there was an error loading the Library and it refers me to this forum :slight_smile:

Bumping, I get this exact issue. Clients say the core is initializing. RoonServer says it’s running. Clients will connect once the Roon app runs on the RoonServer. However, the Roon app crashes almost immediatly.

Roon Core Machine

MacOS Monterey
3 GHz 6-Core Intel Core i5
32Gb RAM
Running RoonServer 1.8 (970)

Can we get an ETA for this fix? This is getting really annoying…

Hey Everyone,

Thanks again for your patience here! We’ve just released a new build (987) that should clear up any issues related to RoonSever getting stuck on initializing. Please update your core to enable the fix.

More details on this release may be found here : Roon 1.8 (Build 987) is Live!

Let me know if any issues persist after updating :+1: