RoPiee + Display + HAT not shown as audio zone

Dear all,

I was in a tinkering mood, and all went kind of well, up to the last step.
Managed to put together a PI 3, a Hifiberry Dac+ -HAT, and the official 7’ touchscreen.
I got the screen up and running (brilliant, btw, I really enjoy it!). now the last step to happiness, configuring the whole thing as a roon endpoint, doesn’t work. The HAT (DAC+) doesn’t show up as an audio zone in roon.
Pi and Display are powered seperately via a USB splitter. RoPiee is configured to use a HAT, USB audio is disabled.

What did I miss?

Did you enable the extention in Roon?
Also need to enable the zone under audio.

that’s weird. there’s nothing you need todo once you have the HAT configured.

Unfortunately I’m travelling to Munich as we speak, so I can’t have a look earlier than Saturday.

Can you send me the feedback? It’s on the advanced page.


I double checked, the extension is enabled.
The pie does not show up under networked devices in audio settings, so there’s nothing to enable.

Please, do take your time. In the meantime I will enjoy the screen and the way it looks and works.

Silly question but does the hifiberry DAC+ show in the ropieee list of DACS in the web ui when you are setting up ropieee? In other words is the hifiberry DAC+ you selected to enable? I R engineer (meaning mister literal details details :slight_smile: ) and when you said it is set to “use a HAT”, a flag goes up for me until it is confirmed that the “right” HAT is configured.

Also, have you tried rebooting everything? Network also. Sometimes that helps. :yum:

Yes, yes and yes. It didn’t help the issue, though. :innocent: Thank you for sharing your thoughts.

How are you connected to the network and were you during the setup process?

I set up ropieee with a wired connection, now I’m on wireless.
I can view and control different roon zones with the touchscreen, so network connectivity doesn’t seem to be an issue.
Maybe the hat is defective, I’ll try and swap it with another dac hat later today (I’ll have to disassemble my headphone listening station).

For the time being, if you can SSH in as root:

Check that your HAT is seen by ALSA:

aplay -l

Check that Roon Bridge is running:

systemctl status roonbridge.service

1 Like

Looks like we’re getting somewhere.
The HAT is seen by ALSA, but if I check for roonbridge running, I get “Unit roonbridge.service could not be found”. What would be the next step?

The easiest way is to reflash the card with a fresh Ropieee image and let the auto install magic happen all over again.

Alternatively, you may be able to install Roon Bridge manually, but I’m not sure if this interferes with Harry’s update system.

I’d choose the former. :slight_smile:

I’ll try. Thanks for your help!

keep in mind that during installation RoPieee requires internet access!

It’s hardwired into the router during installation. Ropieee is installing as we speak, I’ll be away later and report back when I’m back home.

1 Like

A reflash of RoPieee solved the issue. Display works, and the pie shows up in roon under networked devices, together with the other pies.

Ladies & Gentlemen, we have sound! :grinning:

Thanks everybody for your help! It’s very much appreciated!