Ropiee does not connect with NEST Wifi

I have been using Roon on Raspberry pi for several years. Have 4 pi renderers, 3 of which currrently have Ropiee and one DietPi.

This week I started using a Google NEST WIFI mesh. The mesh consists of 1 main unit and 2 extender points.

My Ropiee units connect via WIFI to the main NEST but do not connect to the extender units although when connected with ethernet to setup they show the wifi in the scan. Contrary to that, the unit with DietPi connects to the extender units fine.

What can I do to fix this?

A true MESH network doesn’t have extenders as such. The range extenders form an invisible part of the WLAN and you have a single SSID which shuttles data around the various extenders via the best route automatically.

If you are seeing more than one SSID then you have not got the mesh working properly.

Thanks for your response.

I understand both that mesh does not use “extenders” as non mesh wifi, and that all access points show up as only one wifi to the user computer. Used the term extender to identify the accesories in the explination.
To the Ropiee units the mesh wifi indeed shows as only one ssid signal. However, the Nest wifi app for administration identifies to which of the wifi radio units a client is connected to. That is how I know that the Ropiees can connect to the main Nest mesh unit when it is the nearest one, and sees the secondaries when scanning, but do not connect to the secondaries when they are the nearest ones to the client Ropiee unit.

With mesh it isn’t a case of which access point is closest but which gives the quickest response.

If the main access point gives adequate performance it will not hand off to one of the other secondary access points because that will be a (marginally) slower route because there are more steps in the chain.

Only if the WiFi signal of the primary access point is degraded to the point of inhibiting performance will it hand off to another access point in the mesh - that’s how mesh works.

1 Like

I inderstand.
The thing is that when I move the Ropiee client away from the main unit, closer to one of the secondary mesh units, the Ropiee settings show that the client sees the mesh wifi, but does not connect to the wifi.
The Ropiee does not show as connected in the Nest wifi admin app, neither in Roon.
Again the Raspeberry Pi unit running on DietPi is working OK.

As I say that’s how mesh works. If the connection to the primary access point is ok it’ll stay connected to that even if it is right next to a secondary access point.

If performance degrades and the most efficient route is via a secondary point it’ll swap. It may also route some of the traffic through a secondary access point whilst notionally being attached to the primary one.

How big is the property and where is the primary access point located and the secondary points. Slay are you suffering from performance issues? If not then it is working as expected.

Thanks again.
I understand what you state. The property is 2000sq ft poured concrete walls. The place where the Ropiee is located is not too far from the main hub of the mesh but there are 2 concrete walls between them. The armin app for the mesh shows yhere is an excellent connection between the main hub and the point.

Still, the problem is that once the Ropiee is not near the main hub, it does not connect to the main hub, nor the access point.

On board wifi or with a dongle?

I’m connected to a Mesh network myself without any issues.

LB Link wifi N dongle ( model BL-WN155A).


My apologies Jorge. I understand what you are saying the problem is now.

I think your dongle is not compatible with Ropieee.

According to their website they only support Realtek WiFi chipsets:

You want to go wireless? That’s not a problem. Of course RoPieee supports on-board wireless on the model 3, but you can also plug in an external USB Wifi adaptor (Realtek chipset only).

Regards Danny.

The thing is that the dongle was used ion the same Ropiee unit to connect with the prior wireless router with no problem. Thus I believe it is Ropiee compatible.

I really need to change that text. Nex to the Realtek chipsets we also support a small set of Ralink chipsets.

But, more importantly, there needs to be a huge disclaimer added that states that there are no guarantees. Especially the Realtek drivers are a complete mess.

If you don’t want to use cable and internal wifi the best solution is an external wifi adapter (so not a USB one).


Thanks for your reply.

The thing is tat wired is not a viable option for the place where the Ropiee is located, and internal wifi reception seemed poor and unstable before. Again, the thing is that the wifi dongles worked perfectly fine when I was using my ASUS router before I switched t the Nest Mesh.

“If you don’t want to use cable and internal wifi the best solution is an external wifi adapter (so not a USB one).”

That seems impossible to me :grin:

A non-usb wifi adapter would be one connected to the ethernet (wireless bridge) or is that what you meant?

A wireless bridge with an ethernet connector, like this one:

Just an example, but there are more.
It takes the complexity of the USB dongle (specifically the driver) out of the equation and makes it a ‘cable connection’ from Pi’s perspective.

I understand what you indicate, use a wireless bridge.

No to bug, but what I still dont understand is why did the dongle work with my older ASUS wireless router and does not work with my new Nest mesh wireless.

Again thanks for the responses.

I was searching information on he dongle and its supposed to have the RTL8192cu Chipset inside.