Ropiee + HifiBerry Digi + Issues

I recently bought a Raspberry Pi4, with the HiFiBerry Digi+ HAT.
I flashed Ropiee on an SD card, did the whole installation thing, activated the HAT in the Ropiee options from my computer.
Streaming through Roon via the Pi’s USB out functions properly.
Streaming via the Digital or Coaxial through the HAT produces a terrible hissing sound. It does so after a little while, like 1 minute or so, and th. en sporadically. After about 2 minutes produces nothing but hissing.
I tried with 2 separate DACs, Amps and Speakers, the cables work fine otherwise, so I’ve ruled those as potential issues.
Since the sound comes clean out of the Pi’s USB outs, I’m gonna assume that the Pi itself and the software installation are both fine.

I installed the software with the hat already on top of the Pi.

Do you think I got a faulty unit, or could I have done something incorrectly. ( I included some pictures of the assembled unit)

Any help appreciated!! IMG_20210227_182220|666x499

It sounds like some sort of digital clock sync problem.

Given you’ve found it with 2 dacs, I guess it may be the HAT.

I’ve found Hi Fi Berry support very good, although they will want you to try using their OS on the Pi first, rather than ropieee.

I used a second sdcard to make this easier.

Hey GregD,
Thanks for the reply! Their support is indeed very nice. However, they weren’t sure what it is. The shop I got it from will replace it for me though, they agreed I tested well enough to establish a faulty board was the problem.

What surprised me the most is that I got what I’d consider a clean signal for 30 seconds to 1 minute. I’ll post an update once I get the replacement board, since it seems to be an uncommon issue.

Yeah probably gonna get a second SD. The Hifiberry OS is super clean, the only downside I know of so far is that you can’t run sound through the PI’s USB outs.

To be fair, slow/dirty USB output on old Pi models was the main motivator for developing these HATs (boards) in the first place. It’s not surprising that they don’t support it.

Absolutely agree. I was just noting that if you want USB too, Ropieee is the way to go. Once I get a new board, I won’t be needing that, so I’ll probably go for the HiFiBerry OS, since it’s cleaner imo.

Hope the board switch resolves the issue.

I prefer ropieee myself, but just setup a second sdcard so I could try with HiFi Berry OS and get their support.

In my case it turned out to be a problem with a ropieee update which @spockfish quickly fixed.

Once the problems were solved I switched back.