Ropiee WiFi incompatible with my Router

After hours of troubleshooting I’ve determined that Ropieee is not compatible with the my router.
My router is a Synology 2600AC. It used to work with this router. However, Synology has just released a major firmware update and after applying that firmware I’m unable to get Ropieee to connect via WiFi.

At first I thought it was an issue with the Edimax WiFi adapter I was using on a RPi3B+. So, I tried Ropieee on a RPi4 using the onboard wireless chip and it also fails to connect. This used to work just fine before the router update. The boot sequence gets stuck at “waiting for internet connection”.
I’ve tried both 2.4Ghz and 5Ghz. I’ve cleared the router’s previous DHCP reservations for both RPis. No help. It’s strange that when configuring wireless in Ropieee on a wired connection the “scan” button works and shows me a list of SSID’s.

Then as a test I setup my mobile phone as a hotspot and the RPi had no trouble connecting.

Is there a way to get logs from the RPi since I can’t connect to it when it fails like this?

Could it be a Wi-Fi password issue? Can you try to set on you router a different Wi-Fi pwd maybe without blanks or special characters?

Yeah, I tried that too.

I noticed that in the configuration screen some of the wireless info is not displayed - like the MAC address of the WiFi adapter (this is on a RPi4). Is this normal?

No there should be information there…

Have you tried to enable Wi-Fi and reboot with Ethernet still connected?

Yes, that’s what I have to do so I can go back in and check the settings.
So - if upon reboot with the ethernet connected it detects the wired connection and boots normally. In that condition should the wireless “More Info” show IP and MAC address?

I might add that this is a fresh image I just installed from the ropieee website.

Yes it should

… it should …

Hmmm. What could possibly cause that on a RPi4? That’s fully supported by ropieee.
Like I mentioned this is the latest version I just downloaded? I also saw the same lack of info on the RPi3B+.

Try the synology forum for iOS devices on wifi

1 Like

Maybe a wrong sequence in Wi-Fi configuration.
I just tried (on rpi4 last update):

  • enabled Wi-Fi
  • clicked on configure banner (the pink one that appears)
  • then selected my SSID and set pwd
  • in more info I can find the Wi-Fi IP address and the mac address
    … it works.
    Try to start from scratch … and don’t use the same sd on both rpi4 and rpi3
1 Like

Stefano & wizardofoz - Thanks for your help!
I’ve got it solved!

Since the router was just updated I dived into the settings for the wireless configuration. I found what I think is a new option called Smart Connect that was enabled. It is supposed to figure out automatically if the wireless client should have a 2.4Ghz or a 5Ghz connection. I turned that off and the issue went away. Ropieee connects now - no problem.

Whew!

3 Likes

:+1: that’s fine!

I use the same router, and my settings still have that option enabled.

2022-10-10 11_39_08-Codex Router - Brave

What version of SRM are you using?

2022-10-10 11_40_45-Codex Router - Brave