Ropiee Wifi issue on Pro-Ject Stream Box S2 Ultra

I had no problems getting WiFi going … it was correctly discovered during installation and it is running stable for me so far … :pray:

Excellent - been a while since I tried that, so the developer must have done something. Shows you how Good Ropieee is. Bye Bye DietPi and Volumio.
I’ve manage to run it at around 48 to 55 C. All good.

1 Like

Excellent news. I’m not seeing any networks after the scan. Perhaps the Lakewest version has a different wireless module? Are you able to ssh into the streambox and post the output of the command lsusb.

1 Like

I am :wink:

[root@ProJect ~]# lsusb
Bus 001 Device 005: ID 0bda:b720 Realtek Semiconductor Corp.
Bus 001 Device 006: ID 2772:0230
Bus 001 Device 004: ID 0424:2412 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[root@ProJect ~]#

Thanks Stefan, I have the same

Bus 001 Device 005: ID 0bda:b720 Realtek Semiconductor Corp.

But the Wi-Fi scan finds no networks. It works with the Pro-Ject/Volumio sw (8723bu driver)
Nevermind, I’ll run an ethernet cable. Ropieee is so much better than the Pro-Ject software, as you say.


1 Like

The issue I believe is that the wifi module shipped with the unit has been superseded. The new module seems to work only in some wifi configurations. I have not got to the bottom of it, but it’s not a problem per we with Ropiee at all. I assume over time the Linux module will improve and things will work. For now, Ethernet is stable and works well.

@Aris_Theocharides, for your wifi dropout problem, have you tried blacklisting the bluetooth kernel modules?

Driver for the wifi module will be in the next release.


On a Raspbian Buster default install I compiled the current version of 8734bu driver (from, and removed the realtek-firmware package. I disabled CONCURRENT_MODE in the Makefile, and of course the rtl8xxxu driver is blacklisted in /etc/modprobe.d/

Wifi seems stable now - if a little slow.


Thank you Harry.

With the 2.503Beta version, my steps to enable wifi are;

Comment out the line ‘blacklist 8723bu’ in /etc/modprobe.d/99-ropieee-disable-wifi.conf
and then reboot.
Then use the web interface to enable WiFi, select network and enter passphrase in the usual way.


That is not necessary (and possibly will brake during updates or something else). The latest beta supports it out of the box.

I just re-flashed the streamer, and updated to 2.504 beta. I get ‘Something went wrong while enabling WiFI!’. Feedback sent…



I think you forgot an additional reboot (as the kernel is being updated).
Can you retry?

The first time wifi is enabled, a scan is performed and I can select my network. All works OK.
Subsequently, visiting the network tab gives the Scan for Networks pop-up, but this never completes.

On the command line, iw dev wlan0 scan, produces no output and needs a ^c to return to the prompt.
iwlist does work.
iwlist $iface scan | grep ESSID | cut -d ‘"’ -f 2 | grep “\S” | sort -uf


Interesting. I had similar behaviour on an older version of Raspbian. On the latest Raspbian with the latest pull of 8379bu wifi is solid.

Maybe it’s related to the version of networking tools used in Ropieee?

Just a thought.


But after the first time did you save and reboot?

Yes, Saved and rebooted whenever prompted.

And do you have a wireless connection?

Wireless is working. Just can’t return to the Network tab, as it get stuck scanning.