Ropieee and endpoint drop outs

For my Roon fed Head Fi set up I have an JDS LABS Element II DAC/AMP which is fed from a raspberry PI 4 running Ropieee all into my Audeze LCD-XC headphones. I have a dedicated Intel NUC running Roon server.

I purchased the Element II in May and the set up has run perfectly until yesterday. In fact it’s been awesome until yesterday.

What happens now is when I try to play any track, from my local NAS or from a streaming service, Tidal etc. - the track loads but doesn’t play and the Element II drops out of the audio zone completely. To get it back I either need to reboot the Raspberry PI. or switch the Element II off and back on again.
All other audio zones are fine.

I have sent feedback via Ropieee. Reference 95c72c0b332e1722

The Raspberry PI is wireless and ff=eeds into the JDS LABS unit via USB.

@spockfish harry one for you to look at the feedback on I think

Hi @cooltide

You have a wireless network with a space (’ ') in the name. This is an issue for RoPieee. And although this has been fixed in an earlier release, you still are facing some ‘breadcrumbs’ from that.

I suggest you reflash (with the latest RoPieee image downloaded) and try again.


Okay - thank you - I will definitely try that and hopefully report back success. Having said that everything worked flawlessly for 6 months until yesterday but I’m going to try

Hi there - I followed you advice and reflashed with the latest version from the website. It initially worked briefly although that was on a wired connection but when I tired wireless it dropped immediately as before. Upon retrying a wired connection, I still couldn’t get it to work again.

I tried static IP’s and DCHP but the same issue.

I have attached the latest logs reference e9a72493b4619f8e

BTW - I have independently tested that JDS Labs Element II and it’s working flawlessly on other computers.

Do you think there is an issue with the onboard wifi on the Pi?

Thanks in advance

It is not your DAC, but the network connection.

Forget about static IP’s, just use DHCP as that should work fine.
While WiFi certainly has issues, I suggest you first make sure it works flawlessly with a wired connection.
Have you restarted your Roon server?


Hi - yes, I’ve restarted everything, router, Roon server etc etc.

I can get it to work wired but the second I try it wireless which is the whole reason I have this set up, the problems start and then I cant get it to work wired again.

I’ve just reflashed again and tried and replicated the problem - very frustrating as it worked flawlessly for so long.

Are you prepared to try the beta?

Yes definitely. Where do I find the file?

Go to the ‘advanced’ tab and select ‘beta’ in the update channel.

Never mind @cooltide , I just released a new version that reflects all the latest changes from beta.

Thanks for letting me know - will try today

The good news is that after installing the latest version, I appear to have stability now over wifi - will test over the next few days - thanks!

1 Like