Ropieee .BIN corrupt?

So I’m using Etcher but it’s refusing to flash either the standard .bin or the compressed version. It says the image may be corrupt.

I’ve tried copying across with DD (think this should work), without any luck, also tried Unetbootin but that doesn’t work either.

When I try conv=fdatasync on DD it freezes. Are the current images ok?

Did you try another SD card?

Which version are you talking about, there‘s more than one!

Edit:
Successfully flashed the Pi3 image…
Edit II:
Successfully flashed the Pi4 image…

1 Like

Sounds like a defective SD-card to me…

Hi,

I’ve tried 3 SD cards now, they all say the same.

I have tried versions 7.1-stable.20230818.1069 and 9.0-stable.20230924.1118

I am using Ubuntu 22.04, Etcher 1.18.13, I tried formatting the cards to EXT4 and FAT32 prior to launching Etcher.

Thanks,

Won’t a simple DD command work for this BIN image?

Well, just READ what error is stated: “WRITER process ended…”
i.e. it could not WRITE to the SD-CARD, ergo the file is NOT CORRUPT, but there is either a SD-card problem, or your SD-Card slot or Reader/Writer unit is defective…

It isn’t defective I use it all of the time, I have also tried a second SDcard reader.

sudo dd if=ropieeexl_ose_pi4-2023.9.0-stable.20230924.1118.bin of=/dev/sdb
6471720+0 records in
6471720+0 records out
3313520640 bytes (3.3 GB, 3.1 GiB) copied, 13.6637 s, 243 MB/s

This worked, simple commands like this should be included in the instructions imho, no need for fancy software that causes issue.

You should not format (there’s no need) the disks.
Just write the image to the disk.

1 Like

Maybe a problem with Etcher on Ubuntu?
I’d been using Win 11 with no issues…