RoPieee calling 'home' on the network a lot

I’ve noticed on my Adguard Home DNS that RoPieee reaches out to “” address about 1100 times every day.
What does it do? surely not checking for an update 1100 times a day? :smile:

It does it quite frequently (every 5 minutes). This I’ll increase with the next release as this is left over of the development period and certainly overkill in production. Once an hour or so is fine.

However, even with a check every 5 minutes I don’t come to 1100 times a day, so that’s weird.
Can you send me feedback so I can have a look?


Hi Harry,
It’s dropped to roughly 700 times in the last 24h hours. I notice it’s using two DNS types, that would explain the high count.

Hi Harry,

I just checked this behavior in my Pi-Hole’s logs. The client is my RoPieee. It seems as if it was calling home exactly every 5 minutes, just as you have said. But as there are type ‘A’ and ‘AAAA’ requests, this makes up for a total of 576 requests in 24 h.

This corresponds to the total reported on the Pi-Hole Dashboard (we during the night had a power outage, so for some time there were no DNS requests at all).

BTW, what in this context is notable, though, is how Roon’s own DNS queries have come down to such a small number, that they don’t even appear anymore in the ‘top 10 list’. Not long ago, Roon core server was hammering the DNS quite hard.

Screen Shot 2022-04-28 at 8.00.12 AM

LOL, “”, now there’ s an aphorism (astute observation). :slight_smile:

1 Like

Oh yes, with only two Mac devices on the network, Apple is by far the worst ‘offender’. And I am not even sure why I would see this, as I never connect to public captive networks. Where I live, there are no such HiFi hotspots or networks. Will try to blacklist this and see how it goes…

1 Like

That’s interesting. RoPieee supports ipv6, so that I understand. But what I don’t understand it seems like it is resolving the IP address over both ipv4 and ipv6.

Hmmm… besides increasing the 5 minute interval to something like every 15 minutes, I still would expect only one outgoing call and not 2.

Same for me. Every 5 minutes all 3 of my Ropieee endpoints request

“Captive Apple” was the name of my band in high school. :wink:


Strange indeed, if I recall correctly I don’t use any IPv6 on my internal network.

I think I found the perpetrator :face_with_monocle:

ok… on a more nuanced note: this is perfectly normal behaviour for a client that supports both ipv4 and ipv6.

So yeah you can prevent his by explicitly forcing the usage of ipv4 addresses, but that’s not what is advised to do. And yes, this can result in double DNS requests.

So for now I’m going to leave it like this, expect for the 5 minute interval of course. That I’ll increase for the next release.



Can it be changed to a selectable “Update interval” option? Like 24h/7d/30d/Manual

If set to too long an interval or even ‘manual check’ there will be users complaining that Ropieee doesn’t pickup new updates…

1 Like

Let’s not make this bigger than it is: a simple web service call every few minutes. The interval is going to be bigger than 5, but certainly not a configuration parameter.



Just checked my router reports out of curiosity. Went back a couple of months
I get an average of 300 hits per day to “

I’m not trying to make this bigger or complaining about network traffic but it does clutter my DNS log :wink:
Waiting patiently for the new update then, going to unblock it for a moment every week or so.