Ropieee d74ad0d8b91dbf88

Wired RPI 3b with Ropieee to TEAC 301 USB DAC. DAC shows up in Roon but not as a selectable device as seen in the screenshot.

This same RPI 3b with a HiFiBerry Digi+ HAT exhibited dropped audio. Maybe it’s the RPI hardware but this device worked fine with Moode Audio (without Roon).

Roon works fine with the two Chromecast Audio devices but I’d really like it to work with the wired RPI3 as the wireless network can be hammered throughout the day.

Any ideas?


Some basic questions while we wait for @spockfish to look at the feedback, i assume that is what the “d74…” is in the title of the thread.

Is USB audio enabled on the Ropieee webUI?

Is the Teac “on” and set to use the USB input?

Another basic question, have you power cycled everything?

The DAC is recognized by Roon, however it states that it is ‘disabled’. Can you please check the device settings in Roon?

Thank for all your replies.

Yes, all the settings were correct. I rebooted and ultimately reflashed RoPieee and tried a different RPI3. The TEAC was showing enabled in the Roon UI and I could select it for output but songs would not play. So, playing an album would just go from song to song without anything being played.

Ultimately, I switched back from USB to using a Hifiberry Digi+ to the TEAC and all seems well. I originally switched to USB when I ran an ethernet cable to the RPI3 as my wireless gets hammered and was experiencing the occasional dropout. So far, no dropouts with the DIgi+ and, while it would be nice to figure out the USB issue, I’d rather listen to music so I consider the matter resolved.

My wife did find it amusing that one piece of advice was to power cycle everything. As a software engineer for 40 years, I get IT support calls from family and friends and it’s a running joke that whenever someone comes to me with an issue, I always say, “Did you try turning it off and back on again?”, something I hadn’t thought of, in this instance.

Thanks for all your help,


That was also a running joke on a British show called “The IT Crowd”.


You would be amazed at how many users don’t seem to try this before reporting an issue.

Another ‘support call’ question then: Have you tried a different USB cable to the TEAC?

Yes, swapping out cables is always the first thing I try. Surprisingly, I’ve had cables fail in the past that were just sitting there, plugged in, without any movement or people stepping on them. Perhaps, the flow of electrons wore them out.


1 Like

No that is called ‘burning in’ and it only ever makes things sound better not worse… :grinning:

I assume you have tried the TEAC with other USB sources (and the Pi driving other USB DACs)?

@Paul_Cady ,

Did you read my response?

Your DAC is properly recognized but I think it’s disabled in Roon.


Device shows in Settings==>About, but that doesn’t mean that it’s Enabled where it needs to be, in Settings==>Audio.

1 Like

Yes. If you look at the screenshot, Roon’s UI showed it as Enabled but was not available as an Output. It seemed to me as if Roon was cycling between it being Enabled and Disabled - something the UI was not responsive enough to show. And when I reflashed everything, it did should up as an output but cycled through the songs without outputting anything to RoPieee.

Frankly, I’d blame Roon or my hardware on this and move on. I’m not running Core on “Tested” hardware. It’s a 15 year old AMD FX6100 6 core running Ubuntu Server 20.04. Seems to work fine with CPU load < 10% at any given time.

The same RPI3 with the old HifiBerry Digi+ to the TEAC is working great.


I was always skeptical about burn in but this new setup uses a new Denon integrated amp and I swear, I was going to return it until it ran for a few hours and the harshness just went away.

And, yes, the TEAC works fine with other USB sources. I don’t have another USB DAC to test but I did swap out the RPI3 with the same results. It’s working fine now with same RPI3 and a HifiBerry Digi+ to the TEAC, so all’s good.


When you say it cycled through the songs was this like it was skipping from one track to the next or like it was playing the song in Roon but no sound coming out? If the the latter, what sample rate tracks are they? I have seen, in my system, where it appears the song is playing but no sound come out. turns out that the sample rate in Roon was not “syncing?” with the DAC either due to the DAC or the connection type. In my case I lowered the sample rate to 96KHz from 192KHz in the device setup in Roon and the tracks played fine after that. Not saying this is ideal or the solution but worth looking into, maybe?

Skipping from one track to the next. Hitting Pause or Pause All didn’t stop it and I’d have to Disable the interface in Settings->Audio.

All my songs are 44/16 or 48/24. Sadly, my ears are no longer “high resolution” so I am happy with merely lossless sources.

I have to say, kudos to @spockfish for producing a very nice piece of software. I like things that “just work”.


1 Like