Ropieee does not see wifi network

I have a Raspberry Pi 3 and installed Ropieee. When selecting Wifi it does not see my Wifi network. When I e.g. install Dietpi I can see and select my Wifi network.

Board id: 0000000021044231

Raspberry Pi 3 Model B Plus Rev 1.3

Any support to get this solved ?

Regards, Hans

Hello Hans,

WiFi is a two step process : first enable and then select your network. If that doesn’t work, and after a courtesy reboot, submit feedback on the Advanced tab of the web GUI.

Hi Nathan,

I tried al of that without success. Submitted …


So … you did not configure the wifi, you only enabled it.

Are you saying that if you go into the network tab (with wifi enabled) your wifi network is not in the list? Is there anything in the list at all?


Hi Harry,

Yes the list is empty, nothing to choose.
I have both 2.5 and 5 g enabled on my wifi network.

Thanks for your support.

ok… that’s weird.

Can you go to the network tab again and send feedback afterwards?



this is weird…

it sees that wifi is enabled, but it fails to scan for networks…
hmmm… i know see that something goes wrong initializing the driver…

Can you reflash? Just to be sure?

Hi Harry,

I did that already 2 times without success, I wil retry tomorrow.

Thanks, Hans


New member here.

Posting to say I have exactly the same issue. Feedback, in case it helps is, 67d2eafa73047cbd.


Same here. Flashing 2 boards on a lovely Saturday afternoon of tech time…Same issue on both boards. One is a Pi2, the other a Pi3. I have configured a few other Pi endpoints lately and the WiFi setup is not behaving as expected today. I assumed I’d received a bad board until the same thing happened with another :slight_smile:

@Hans_van_Loon @Paul_PIERONI @Todd_Burke Sorry guys!

This is a regression coming from the kernel update. Update is out there that fixes this.


1 Like

Sorry! I am new to this software. Are you saying this will be fixed in a new release or do we have to find and apply something?

Many thanks.

1 Like

The unit will update automatically. Go into the webpage: either it already pulled it in on boot (and is now suggesting you need to reboot), or it says that an update is available and you can just click it.

And the problem is resolved.

Thank you very much for the quick replies and fix.

Problem resolved, thanks.
Is it possible to have the phone jack activated as audio output ?

Regards, Hans

No Roon and Ropieee will only work with digital output the pi’s audio out is very poor indeed and suffers from interference.

There are HATs which provide this functionality (I happen to use HiFiBerry), if you need it.

Just ordered HiFiBerry DAC+ - Phone jack, hope this will work.

1 Like

I have installed RopieeeXL from “20191117-ropieeexl-ose_rpi234-stable.bin” on both a Raspberry Pi 3B+ and also a Raspberry Pi2 with Edimax wifi dongle and have the same issue. Is there anything I am missing?