Ropieee doesn't show up after changing network to Rock bridge/router mode

Last evening we are playing around with Ropieee and it was working perfect after some minor issues. But this morning I changed the network config from directly connected on the switch to directly connected to Rock. But now, ropieee doesn’t show in Roon anymore. Both leds on the ethernet side are flashing green, so there is a connection but probably not the right one…

Is it possible to connect a Ropieee (Raspberry Pi with DigiOne) directly to your Rock?

(Both sides are using DHCP)

I’m not sure. Does Rock do DHCP?

And … why would you want to do this?

Yes, Rock does DHCP or Static.

Had some good experience with this way, and skip the (noisy) switch.

Well, then it should work. Can you send me feedback?

That would be difficult because I’m not able to find Ropieee on the network at the moment.

1 Like

uhhhh yeah :wink:

Maybe I have to try it with a static IP?

Info from Rock Ethernet2 (DHCP):

IP Address:



DNS Server:

Did anyone tried this before? Is Ropieee working without an internet connection?

RoPieee requires an internet connection.

The IP address above suggests that your ROCK is not connected to a DHCP server.
Are you trying to set them up without any other infrastructure?

Rock itself is working, I can use Roon on all the other endpoints. But he don’t update the Gateway or DNS Server in DHCP mode on the second Ethernet connection. Not sure why. But this is working with my windows 10 mediacenter. Only there was no internet connection.

Rock is connected to ethernet1 with DHCP on an other IP range.

So, when Ropieee can’t find any internet connection it will not start completely and will not work?

I’m afraid that the issue is the internet connection, have to try it with a static IP and maybe a DNS server configured.

it will start, but will lack NTP. That is an issue.

Why not use some Fibre media converter for the rock 1gb and rip 100mb if you think optical isolation will help

Okay, Than I have to find out how to get an active internet connection to the Ropieee.

Maybe this thread will help?


The internet looking interface will need a valid DNS and gateway setting, which are usually supplied by DHCP, the local “point to point” interface (set statically) does not. Also, make sure the link lights light on the local interfaces, as you may need a crossover cable (if the ports are not auto sensing).

Awesome, it’s working!

Have to run now, but will explain/post my settings later. :joy:

1 Like

Using a static IP was the solutions for this. I used the following settings on Ethernet2 from the Rock:

IP Address Setup: Static IP
IP Address:
DNS Server: [My Local IP Gateway/Router, mostly this is something like or]

In Ropieee:
IP Address Setup: Static IP
IP Address:
With same gateway and DNS

I’m not sure if I can connect to Ropieee web client now, but will figured out later. For now it’s working perfectly, and plays very nice.

This IP addresses are in a self assigned rage…you should really used fixed IP addresses in something like the rages where xxx is the same for both and yyy is different

You’re right, It’s better to not use the 169.254.x.x range, but on the other side, it will work with this range :wink: