RoPieee End point disappears (1second)


(Rob Schatz) #1

New RaspberryPi 3 B+. USB connected to DAC (Cambridge Audio Azur 851D). After booting up RPi, Roon “sees” the endpoint for about 1 second, then it disappears.
Tried with two other DACS, Dragonfly 1.2 and KingRex- those worked fine.
With the Cambridge, tried rebooting Roon, DAC, RPi, MacBook Pro, with same result: If the Cambridge is rebooted- the end point shows up, then immediately disappears. I captured a screenshot below before the disappearance.


(Harry ten Berge) #2

The Cambridge is known for it’s not-so-good USB implementation. have you looked at the settings on the Cambridge?


(Rob Schatz) #3

Thanks for the reply, Harry!
Yes, I have looked at USB settings on the Cambridge. The only USB setting choice that I am aware of is the choice between USB type 1 and type 2. The USB 2 is the one that disappears. If I change to type 1, the zone shows up and stays around- but tracks do not play: They just skip endlessly from one to another.
When not using RoPieee, I use Dirac as a zone playing via USB from a MacBook Pro into the Cambridge Audio. A zone (not used) appears in Roon described as Cambridge Audio Azur 2.0, or something similar to that.
That exact description is what shows up as a networked zone before is disappears. Is Roon somehow seeing that description as a conflict, which leads to the networked Zone with the same name disappearing? If so, what would the remedy be?


(Harry ten Berge) #4

Yeah these are known issues with the CA’s faulty USB implementation.
I think what should work is that you switch to type 1, but afaik it’s then limited to 96k.

For the rest there’s not much I can do. There are people on the forum that contacted CA about this, but no luck so far.


(Rob Schatz) #5

Unfortunately, using type 1 USB only results in perpetual skipping.


(Harry ten Berge) #6

you’re not upsampling or something?


(Rob Schatz) #7

Per Cambridge Audio website:

“All data is put through our 2nd generation Adaptive Time Filtering that upsamples everything to 24bit/384kHz hi-res quality, no matter the original source”

So yes, the signal gets upsampled. Does that somehow inherently disqualify the Cambridge from playing nice with the RoPieee?

My interest in the RoPieee endpoint is for the upcoming release of Dirac Live version 2.0 that is rumored to have plugins that allow the Dirac DSP to be used with endpoints other than when a computer (e.g. MacBook Pro) is the endpoint. My hope was/is that RoPieee would serve as an endpoint when Dirac 2.0 is released. Of course, if we can’t get the Raspberry to work when connected to the Cambridge, well…


(Harry ten Berge) #8

No it’s not related to upsamling.

It’s just that there are problems with CA’s USB implementation.
There are more discussions about it on this forum, like here: Cambridge Audio CXN no longer working on USB


(Rob Schatz) #9

Thanks, I’ll look into the referenced topic. To your knowledge, does Cambridge Audio seem to know about the issue and do they seem inclined to rectify the problem?
Are you aware of other endpoints that utilize USB and work with Cambridge, or does one have to use TOSLINK or Coax inputs. Something like an audio HAT?


(Harry ten Berge) #10

I think there has been some communication with CA.
I’m not sure what the status is, but I expect them to give a nice statement like:

“our products follow the USB 2.0 standard and are compliant.”

The CA works if you use a Mac or Windows machine. If it’s Linux (like most Raspberry Pi solutions) you should think of switching to coax. Allo’s Digione is a fine HAT for example that is suited for that.


(Rob Schatz) #11

I recently began a conversation with Cambridge Audio with background on the problem. Below see their most recent response.

"Thank you for the information and the pictures.

**Our engineering team pointed out that it seemed like you were using something that seemed like an adapter from the USB into your Macbook and the RaspberryPi. They recommended trying the connections without the adapter to see if that helps. Also, just a few questions from the engineering team: **

*** What operating system, distribution and version, are you using on the RaspberryPi?**
*** Which version of Roon are you using?**
*** Can you link us to the Roon Community user boards that you mention?**

*** Can you please provide the output of the “dmesg” command in the terminal after plugging in the 851D?"**__

I replied with detailed answers to the above questions, including screen shots of RoPieee details and terminal output.

We shall see…


(Rob Schatz) #12

Update from Cambridge Audio today:

"Hello Rob,

Thank you for your patience.

Our engineering team had two suggestions:

  1. ssh into the RPI, plug in the 851, then provide the output of “dmesg” or “sudo dmesg”.
  2. Try running Roon on Ubuntu 18.04 instead.

They also found an article that had a fix for a situation similar to yours:

Thank you and hopefully this helps.

Best Regards,

Joseph Buechel
Cambridge Audio"

Unfortunately, Joseph lost me at “Hello”.

Harry, can you comment and perhaps decipher? Finally, can Roon @support become involved?

Good thing I have other listening (connection) options…


(Rob Schatz) #13

@support
Anyone?


(John) #15

Hello @crummwoody,

I’m sorry to hear you’re still having issues, I’m taking a further look into this. Thanks for the assistance as always @spockfish.

We’re also going to reach out to Cambridge Audio to see if there’s any way we can do better here.

Thanks for your patience, I will be sure to keep you updated going forward.

-John


(Rob Schatz) #16

Thanks John,

As a lifetime subscriber to and big fan of Roon, I’m happy to see you are on the case. Also, thanks to @Spockfish.
As earlier, hoping to use MacBook Pro as core with different endpoint to maximize SQ. My timeframe is fortunately flexible as I’m hoping to utilize Dirac Live 2.0 (not yet released). Long term happy user of Dirac Live 1.x.
Please let me know if I can provide any additional information.
I became concerned today as I was reminded by Cambridge that they were ready to close the case…