Ropieee extension

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Spectrum WiFi and ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Hifiberry DAC + Pro.

Description Of Issue
Nothing works black screen.
Rasp Pi screen asking if Ropieee Remote Control Extension is enabled in Roon, but I cannot find any mention of that when it used to work, now phone and PC only display black screen

BLACK nothing else.

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Rasp Pi 4 Ropieee Hifiberry DAC+ pro

Description Of Issue
Start Roon, frame appears nothing in it but that sphere with lines dancing, same on phone
Blank screen with ball in center NO CONROLS
Exact same setup that was working a few days ago.

Hi @richard_austin,

What kind of Roon Core are you using? Please provide details regarding your operating system / specs / network, you can use this thread as a guide:

Can you share a screenshot of what you see under Roon Settings -> Audio for the Roon interface?


What do you mean by what kind of roon?
How many kinds are there?
You keep puttingh this on me when it’s YOUR roon that only displays a black screen’
It worked last week annd now it doesn’t.
I changed NOTHING.
What KIND of Roon shows nothing but a black screen on PC and phone

I think the question was about this item: Core Machine (Operating system/System info/Roon build number)

To get support from Roon you need to tell them about your set up so that they can work out what is going on, otherwise it would be like the blind leading the blind.

Your Roon Core can be set up standalone on a PC, Mac or Linux computer with the all in one package.
It can be set up headless using Roon Server.
It can be set up using the ROCK OS on a NUC or even unsupported hardware.
It can be set up on the turnkey solution that is Nucleus.
It can even be set up with Roon Server and Roon running on the same computer.

Tell support how your system is set up so that they can give you the support that you require.

I have an Audiophonics Rasp Touch w 7" touch screen.NOT using their power module YET…
Rasp Pi 4 2Gb, HiFiBerry DAC + Pro.
Standard Ropieee.
Spectrum ISP router/ wifi
Wifi enabled.
On ethernet too.
Hewlet Packard i3 quadcore, SSD, wifi dongle. (new) windows 10 Pro 64 latest update, connected to ethernet.
Samsung android (new)
HiFiBerry line out to amp and speakers.
I’d like to search Tidal with 7" touchscreen, but can live with having to use phone/PC
I have no digital music, but may rip CDs to SSD storage.
Tidal is my main concern. Rasp Touch next to listening chair.
Anything else?

Er, how is your Roon Core set up? Is Roon up-to-date?

Using the standalone version of Roon or headless with RoonServer on your PC?

By the way I am just another user, I am not support.

Set up?
I just uninstalled Roon, Downloaded and installed today’s version.
I previously uninstalled Server and Bridge.
Just “Roon”.
I want noise to come ONLY from my Hi Fi, not the PC or phone so I disabled them.
Do I want my “device setup” for HiFiBerry DAC+ to be a private zone?

There is nothing in or under “Extensions”.
Touch screen says Connection failure.
Wi fi is setup and ethernet is connected

No audio devices are found

You may have already done this Richard but have you gone into the Ropieee WEB UI to make sure everything is set up correctly?

Oh Yeah! Not sure what “properly” means though.
Under display I have entered every “zone” name , rebooted and still no cover art or audio controls. On Remote control page is my phone the remote or is this about an actual remote control?

You should have everything using the same zone name in ropieee and roon audio and extensions

If your core is on windows then try turning the firewall off

I don’t seem to need spockfish as I have no remote.How do I get appgineer?
I turned off firewall rebooted RPi 4. No album art.
Clock and failure notices work great.

Do I need bloodwaLCD?
Where do I find it and how do I enable it.

BoodwahLCD is the name of my ropieee zone

You would help yourself here by posting screens shots of the ropieee for us to see what you have done wrong.

I assume you have installed ropieee from a freshly flashed sd card, if not then go back and do this.

If you haven’t read this I strongly recommend you do so

I figured that out after renaming my RaspTouch. It mad no difference if that means anything to you…
What’s funny is all these Roon Pros recommending the beginners guide. after being unable to fix user’s issues…
I have read it.
Probably some update did this and might undo it later.
Thanks all the same.
I do appreciate your efforts.

FYI I run 3 RPi displays with ropieee and several other ropieee installs on various hats and combinations. This is I doubt an issue with roon but something you have configured incorrectly so if you can’t be bothered to post your screen shots you won’t get any more advice from me.

I’m going to move this to the ropieee area too.

Maybe @spockfish will help if you send a feedback to him

In line with @wizardofoz… have you enabled the RoPieee Remote Extension?
Without that the display is not going to work.