RoPieee LCD Beta stuff - tell it like it is

@volpone have you tried reseating the ribbon cable? Maybe it’s some weird dirty contact perhaps. Or a faulty unit. Assume you are not getting any lightning bolt icons etc either. Are you running the original RPi power supply as this is what I am using? This powers both devices no problem here.

I’ve got the "lightning bolt " icon.
I’m not running original RPI3 PSU but ifiPower 5V 2.5A PSU.
I will try again double checking the connections and using 2 distincts PSU for PI and screen.

Harry my digiamp+ setup this morning after the boot time was with normal last played screen, play button worked fine and volume was I believe the same as it was when last played…But it’s now still indicating 0.3.3 while the other 2 setups are 0.3.4 now so maybe it didn’t reboot…I’ve done a feedback just now for you on that unit.

The additional data display is misleading as it’s the monitor zone pairing and not the host name of the PI.

Oh duh! you’re right. It should not be the zone of course but the hostname. Djeez.
Ok. Correct that asap.

on a sidenote: my Digiamp+ arrived yesterday, so during the weekend I can have a look at the volume stuff.

Awesome Harry! Hope you like the digiamp+. Did you also get the 19vdc smps or do you have one maybe from something else…but I’m told 12-19v should work too

@spockfish just sent the feedback on what appears to be a non reboot unless it missed the software update time

UPDATE I just checked again this morning and the extension has still not updated to 0.3.5 so let me know if you found anything in the feedback sent.

I’m going to force a reboot now.

UPDATE#2 Rebooted… no change…shutdown and power again also no change… timed reboot also no change still stuck on 0.3.3

The other 2 LCD setups both rebooted ok this AM and are now at 0.3.5 and are happily now showing the HOST Name :smiley:

Ok guys. Just pushed another small update to the beta channel. This is the last release in the beta channel, the rest of the weekend I’ll spend on integrating this stuff with the stable release.

Here we go:

  • @Geoff_Coupe’s circle and smaller icons are in place.
  • Zone is being displayed
  • Extension shows the hostname (this time it’s right @wizardofoz :wink: )
  • Web interface: when rebooting/shutting down navigate back to ‘/’

Could someone post a picture of how the display looks in the latest beta?


Harry, willl we be able to easily switch to main channel or will it require a full reinstall.

Great work Harry. Much appreciated all of your efforts on so many things you have put in of late. Hope you get some donations :grin: See the bottom of the page for how to donate :money_mouth_face:

My failed updates is resolved…Harry to the rescue and all sorted :smiley: thankfully via the command line, not having to dismantle the display case.

Guys, great news!

I’ve got hardware rendering reliably working, which means that scrolling texts are back on.

This means a slight change of plans though: I first want to test this out in the beta channel, so we’re gonna prolong the beta period just a little bit.

Not sure when I can deliver this. I’ve got it working over here, but I need to do quite some cleaning up before I can make this available, so be patient :wink:



wow! :thumbsup:

Hey Harry @spockfish

My old man has been leaving his Ropieee Touchscreen Digi+ PRO on all week since the screen turns off.

His auto daily reboot is set to 3AM.

He said last night after he finished Roon-ing, he watched some Wimbledon :tennis: Then before he went to sleep, he checked that the Touchscreen display had turned off, as usual - and everything was good so he went to sleep :sleeping:

This morning he woke up and the screen was on, and it showed the 2 lines about “Roon is not connected” so he was surprised :open_mouth: the screen was on when he woke up.

I just asked him what version extension he is running and it’s 0.3.3 still.

So it seems it did the usual 3AM reboot but for some reason it didn’t update but also the screen didn’t go to sleep after the 3AM reboot this time.

He’s done a reboot and it still hasn’t updated.

I had the same problem at my end but I just wiped my SD card and did a fresh install and it’s fine - it pulled the latest v0.3.3.5 on the fresh install for me. But he wouldn’t know how to do a fresh install.

If it doesn’t self update for him, that’s fine, I’m happy for him to leave it with version 0.3.3 until I visit him :red_car: :oncoming_automobile: next weekend.

But just some feedback for you, because the auto-update is a cool feature but for the first time, it didn’t work smoothly for him and me (but it’s more of a problem for him :older_man: than me :baby: ).

Same problem I had…it’s an easy usg ssh fix, if you have teamviewer or the like on your dads pc/mac you could remote in and sort it out.

Ya but ext 0.3.3 is working fine and more importantly RoonBridge and HiFiBerry is un-affected so Roony Tunes :notes: can keep flowing until I visit him next time

A few weeks ago I requested that the automatic 24-hourly reboot be disabled (or an option) because I envisaged this exact issue may come up with dad’s setup. So maybe something to consider for the ‘main’ release Harry?

It’s partially in there already or at least some indication of it’s potentially being in there. When you do a commit there a 1 value for auto reboot.

Interestingly the 2 lcd setups I have without hats have updated no issues from 0.3.3 to .4 then to .5 so maybe it’s an issue for those with hats and lcd.

1 Like

Yeah your correct. This issue only affects those that run a touchscreen.

1 Like