Ropieee.local vs IP address


I have two RPi running as Roon bridges using RoPieee. One has been installed for a long time, the other one was just installed today. I can access both Pi using ropieee.local however if I shutdown the older (first) divice I cannot longer access the new one using ropieee.local but I have to use the IP address instead. Conversely if I shutdown the new device the order one will still appear under ropieee.local.

Here is the breakdown for clarity:

Old Pi on + New Pi on = as expected both show under ropieee.local

Old Pi on + New Pi off= as expected only the old Pi shows under ropieee.local

Old Pi off + New Pi on = ropieee.local doesn’t work and the new Pi’s IP address is needed to access it.

For convenience I would like both devices to be accessed using ropieee.local all the time regardless of which one is on or off.

Any suggestion?

Thanks in advance

ropieee.local has always been problematic for me with multiple devices. I just assign fixed IPs to my RasPis. When you call up the Ropieee Interface for one device through its IP address it will show all your Pi’s under “devices” and you can access the others from that config page. That means you really only have to remember one Pi IP.

Rename your RPis some names other than Ropieee.

E.g., Umptyfratz can be accessed as Umptyfratz.local

I use Selene.local and Luna.local (because they’re satellites, get it? :grinning_face_with_smiling_eyes:)


I have already assigned fixed IP addresses to both but still ropieee.local only opens if the old Pi is active.

The problem is caching on your client device. The easiest solution is to reboot, and this will likely clear everything up. Depending on your OS there are also commands if you need to avoid a reboot or force the issue.

However, even better is to name the two pi’s differently, even ropieee and ropieee2.

The device is an iPad Air and rebooting it didn’t solve the issue.
I had also rebooted the RPis several times.

That’s exactly how I named them.

I believe that turning Airplane mode on and off will flush the dns cache. I am surprised that the reboot didn’t work to set the correct IP address.

That didn’t work either.

Reboot the router.

That solved the problem.

In that case you need to access it like that:

ropieee2.local instead of ropieee.local

I talked too quick, it is not fixed.
Still same problem

I tried that. The problem is that using ropieee2.local can access both Pis, but if I turn off Pi2 then ropieee2.local won’t show Pi1 (only ropieee.local does).
What I looking for is a single login that shows both (if both are on) or just one if either one (1 or 2) is off.

Can’t figure out what you mean by this.

If you name your Ropieee devices with different names then you can access all of them, or rather the ones that are running, here -

There is no one ring to rule them all.

1 Like

I know is kind of confusing

Here both are ON under ropieee.local

Here both are ON under ropieee2.local

The problem is that if I turn off Pi1 under ropieee.local then both disappear and I cannot longer access Pi2 using that login (roopiee.local). It just won’t open to show Pi2 (which is still ON)

In a previous setup that I had with two Pis I only use a single login (ropieee.local) and both or either one will show regardless of which one was off.
Now if Pi1 is off I have to use a different login (ropieee2.local) to access Pi2.
I am looking to use a single login (ropieee.local) for both (both on or just one on) Again I have to switch to ropieee2.local to access Pi2 if Pi1 is off.
Clear as mud?

Sorry, but I think you are mis-remembering. It doesn’t work that way.

Yes, that’s the way it works. You have to use the appropriate logon to access the RPi. You can’t use a logon for the RPi that isn’t active to access another RPi that is active.

You wouldn’t try to use an IP of an inactive Rpi to access an active RPi, would you?
An xxxx.local is just a nmemonic for an IP address.

My (mis)understanding was that a single login (ropieee.local) would show every connected device (both or just one if the other was off). That’s the way I recall my previous set up working but as you said I may be mis-remembering.
Oh well, just another case of “can’t have my cake and eat it too”.
Thanks everyone.

1 Like

I reserve IP addresses in sequence as .4x/5x for lan and .14x/15x for wifi connected ones. All my pi’s have a LAN and wifi connection defined - but normally I have a browser tab open with one and navigate to all the others from the devices tab

1 Like

You can give each RoiPieee instance a unique name on the “Roon” page of setup. Mine are Gumby, Modi, Modius, and HiFiBerry named after the connected DAC. First 3 are the Schiit Audio devices connected by SPDIF. The last is a HiFiBerry DAC2 Pro feeding a Tivoli Audio table radio.

This has been the easiest way to keep them straight. Follow DNS conventions for forming host names. Letters, numbers, dash, and underscore are legal.