RoPieee looses USB DAC [Resolved: inadequate PS]

@spockfish My RoPieee (on a Rpi4) looses the DAC. Any traces of what happens in logs? Feedback 3d4758ff8bf1027c
DAC comes back only after a cold boot of the Pi

EDIT: should mention that the DAC is USBPre2. There is a ISO Regen between Rpi and DAC.

DAC is not visible at all. Have you tried without the Regen?

So far I have not tried without. The Regen delivers bus power to the DAC. PS I use is still too small for both pi4 and DAC. aplay -l says no DAC exist when this happens. This might have something to do with Roon itself as I think it happens after Roon has done a data base backup (scheduled every other night at 02:00). No sign in the feedback?

stopped Roon core. DAC is still there. Forced a Roon backup, DAC is there so my Roon suggestion in the previous message is probably not valid. New feedback d1609562ec949073
I’ll try without Regen as soon as I have a better (bigger) PS

@spockfish DAC disappeared again last night. Feedback is from about an hour after: 4ed036de7fc74bfd

@spockfish Yesterday I upgraded to XL. I’ve not lost the DAC since then. I sort of doubt that the upgrade fixed it - not alone at any rate. The ISO Regen only draws 20mA. Maybe this is just a little too much with the PS I currently use. I now feed the ISO input side with a separate PS so it doesn’t load the pi at all. If I’m right here you may see power warnings in the feedback I sent. Anyway there is no hurry now! Take care and use your time well!

@spockfish my RPi 4 just began randomly dropping my USB DAC (RME ADI-2) after months (years) of zero issues. Feedback b07511b9eb40d93d

Not sure if the issue is the same as or related to the OP’s. No USB gadgetry, just a cable into one of the USB2 ports on the RPi4. A reboot of the Pi fixes the issue until the next random drop. Primarily streaming Qobuz.

Edit: I also just noticed that not only is the USB DAC no longer recognized but the Flirc USB IR controller also disappears until a reboot of the Pi.

So far my DAC is connected, but the disconnect often happens during night. We’ll see tomorrow…

EDIT: DAC is still there, no disconnect during the night. I’m quite hopeful now

Hi @ogs,

Looked at the logs and indeed the DAC disappears. There’s a scary message about the Regen so I would definitely test without it.

The other thing I noticed that RoonBridge crashed (that’s very rare). I’m going to take precautions that it can recover from that. (but it won’t solve your issue).

I’m very curious how your unit behaves without the Regen.


HI @Wakajazz,

Unfortunately there was an issue with my VPS so I don’t have your feedback file :frowning:
If it happens again then resend please.


I will try with Regen removed and report back. I want to test with bus power from pi so this will have to wait until I get a proper PS for it. After the lockdown…

@spockfish DAC (and Flirc) disappeared. Feedback ID 8b19d09d30cf47b4.

This was after a fresh re-flash of the sdcard I did as part of troubleshooting this.

I know this sounds stupid, it did not arrive again due to issues with my VPS :frowning:
It should be resolved now, so let’s see


Here you go @spockfish ca2a65bc578f234f

Hi @Wakajazz,

There are a lot of buffer overrun errors reported by RAAT.
The USB device does not disconnect however. This is really weird.
Overrun suggest that the DAC is not reading them properly or fast enough…

I want to be sure, so I’ll build a new kernel with the latest patches so we can rule out the Linux kernel.

I’ll keep you posted.

Thank you Harry. I may have sent the feedback before the DAC actually disconnected as it takes a minute or so from the time the music stops playing to actually seeing the DAC disappear from the Roon GUI and the USB Flirc dongle disappear from the RoPieee GUI.

Ah ok. It looks like the USB is locking up.

I can resend feedback if that helps? I have not rebooted the Pi since it freaked out. I did power down the USB DAC though.

yes please do!