RoPieee Loud Static Noise


(Tim Wilson) #1

I have RoPieee running on a Rpi 3B with a Khadas Tone Board connected to it. The Tone Board is a USB DAC which is powered by the Rpi. It feeds signal to my STAX system.

There has been a few times now that when I get to the end of an album radio takes over and I get a loud blast of static noise in my ears. This painfully loud noise lasts a fraction of a second and then no music will play. Roon will just keep advancing to track after track trying to find something that will play until I stop it.

If I reboot my Core it still doesn’t work. If I switch to a different endpoint without rebooting the Core it works. If I reboot RoPieee it will work again. And if I unplug the Tone Board and plug it back in then it works again, so it seems like a compatibility issue with the DAC and RoPieee.

I have been able to replicate this issue by using the radio feature. It seems like a change in sampling rate may be triggering the problem. Does anyone have any idea as to why this is happening?


(Mr Fix It ) #2

Try fixing the sample rate and bits to a fixed value in dsp setting and see if that helps. Perhaps it too is suffering the xmos Linux bit rate change bug noted elsewhere in the community here


(Tim Wilson) #3

Thanks I’ll try that. Hopefully there is a fix for this bug in the future.


(simon arnold) #4

See this
https://community.roonlabs.com/t/dac-issues-with-xmos-usb-chipset-and-roon-on-linux/52911/33


(Phil Kemp) #5

I too am seeing this. Here is the feedback link…

0ce0a9ca33ffdff6

Phil


#6

Same here with M2TECH Young MKIII DAC via USB. It happen often when switching from 48 kHz (Radio station) to 44,1 kHz.


(Harry ten Berge) #7

See the thread mentioned by @simon_arnold.

Roon is looking into this and is in contact with most of these vendors. Stay tuned.


#8

Today I’ve got a firmware update from M2Tech (USB V1.30) and until now no problem with static noise.