Ropieee no longer visible as Roon Audio Device

Core Machine (Operating system/System info/Roon build number)
QNAP 269L Version : 1.7 (build 610) stable Raspberry Pi 3 running RoPieee

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ubiquiti UniFi

Audio Devices (Specify what device you’re using and its connection type)
Combination of Wired, Wifi, USB … this its issue relates to Raspberry Pi3b+ with HiFiBerry DACPro+ Wired or Wifi.

Description Of Issue
Previously Pi3 connected to Roon as a zone ie Rpi visible and selectable. Appears that Since one of the roon updates the device disappeared from the Zone list although, any DAC connected the the PI’s USB ports would still show as a Zone ie Dragonfly and I could use Roon through that DAC. ie could Roon to a Pi USB connected DAC but not see or access the Pi and thus not stream to the HAT attached. Ie, I cannot add a Pi to the audio device list. I have multiple other devices still connected. Pi is visible on Ubiquiti network and can be accessed.

Appreciate any advise as to how to resolve adding this new imaged RoPieee Pi.

Can you show us the rpi main web gui page with the setting shown

In this mode I can now see and enable a DAC attached to the USB but still not the Rpi.

Can you share a screenshot from Roon: Settings > About. The Pi isn’t visible as an endpoint since it is a bridge, but it should be listed here.

Hi Martin … thanks for the pointer. Listed as a bridge but as it has a HAT, should also be listed as an Audio device too. This has lead me to wonder; maybe an issue with the HAT so I will try a different one.

Yes, but the audio device is listed under Settings > Audio. Make sure the devices are enabled.

If they’re not present then open the Ropieee web interface and confirm on the Roon > Audio HAT tab.

@Martin_Webster thanks for the pointers. ‘About’ Tab new to me and this helps identify that the RPi is connecting. With some board swaps, it look like I may have a faulty HAT as it seems to load Ropiee ok but not visible. Put what appears faulty HAT on another Pi and same result.

What I have leaned is the Pi only appears as a audio advise with a HAT loaded. On it’s own it just appears as a ‘Bridge’ device. Good to know.

I’ll do a bit more swapping at the weekend to prove but thank you for guidance.

I assume that you have used the Ropieee web administration page to choose your HAT from the drop-down list to enable it? And once chosen, Ropieee will ask you to reboot it to make the changes…

Yes especially as it has been woking ie visible as an audio divide previously

1 Like

Have you cloned the SD card with an existing RoPieee install by any chance? I’m using four RoPieeeXL installs with AirPlay for compatibility with some other hardware. I’ve noticed a couple days ago that only one RAAT endpoint and only one Roon Bridge is showing up in the settings. Might be an issue of duplicate IDs? @spockfish, any way to fix this? :slight_smile:

Yes, duplicate RoonBridge ids are a problem.

I also found out that one can’t clone RoonBridges.

1 Like

That’s too bad. Is there any way to force a different id via SSH?

Yeah, don’t know about Ropieee. Under DietPi, which is were I ran into the problem, I just reloaded RoonBridge.

It’s a pain in the ass with four devices to re-flash the cards, but there’s always that last resort (of course).

@spockfish will have the definitive answer.

1 Like

Just to follow up here, I was able to get around the issue with similar IDs by connecting via SSH and editing the id to something else in /var/roon/RoonBridge/Settings/unique_id. A restart later my four RopieeeXL zones showed up as individual RoonBridge outputs for my RoonServer.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.