Ropieee not detected by roon

Hello Folks,

i have a Rasp3 + Hifiberry which was working fine with roonbridge, wanted to try ropieee to get airplay on top of roon. Installation seem to work fine, got the webui, follow all guide.
However, the RopieeeXL is not detected in Roon. Sent a feedback with ID 88ef1dc5b7a9b114

Thx in advance for your feedback,


did you connect your dac to the raspberry via usb? Ropieee is only recognised as a raat endpoint in Roon when the dac is turned on.
maybe it’s the same with (sh)airplay?

hope this helps

Hello Koen,

Thanks for your reply.
the DAC is a Digiberry pro + into the Raspberry. It was working fine with Dietpi.
I dont really know how but when i turned airplay it was detected as an airplay device and it worked but not a a Roon End Point. Do you mean that Ropieee can only work with a USB DAC ?



Ropieee works not only with USB DACs, Coax and optical input DAC’s also work. But the DAC has to be powered on for detection.

Hello, in my case the DAC is powered by the Raspberry pi so i expect it should work.
I captured on my IMAC traffic on the LAN and i can see MDNS multicast traffic from the Ropiee so i suppose Roppie seems to advertised itself to the network and Roon should detect it. Rooncore is running on MACOSX Catalina.
Roon detects AppleTV properly but i dont use it for music.

Can you screen shot the ropieee general tab in the GUI?

Here it is !

I think you have the wrong hat try this one digi+ is an amp hat iirc

1 Like

Yeah, the Digi+ Pro is a coax/toslink HAT.

Probably doesn’t want ‘Audio USB’ enabled.

Usb enabled should still work, in case you want more than one dac option like a dragonfly or other usb to attach for some reason Like a headphone rig

It is a HIFIBERRY DIGI+ PRO, i double checked with 1 coax/toslink connections so i think i choosed the right audio HAT in the GUI



Sorry for the typo i confirm i have a HIFIBERRY DIGI+ PRO :wink: in my Rasp3 and it is workding fine with my dietpi (with rool) SD card

I have the same HAT.

It doesn’t show up in Settings==>Audio?

Here is mine Enabled. Note, I renamed the Host Name to Selene.

1 Like

What does your Ropieee XL section say -

I don’t understand this comment.

What are you using to send a signal to your DAC? The HAT or USB?
I don’t think the DAC will be powered by USB, if it’s not getting a signal from it

That would explain why Roon can’t see it.

In my case there is nothing in room in audio section.

Sorry not to be clear, it seems i have the same config than you which is RASP + Hifiberry Digi+ Pro plugged into rasp motherboard

Here is my RopieeeXL config

I would try reinstalling Ropieee and reseat the HAT. It sounds like for some reason Ropieee maybe not seeing the hat so Roon does not. You installed the OS with the HAT already connected to the pi I take it?

You only need to configure it in the main settings for Roon, which you already did looking at you images. Did you apply it and reboot as it prompts you after doing this? Any changes in Ropieee need to be saved and device rebooted to take affect. The other options under Ropieee XL for Spotify etc have no effect on the Roon side it just tells Ropieee which DAC to use for as you could use a 2nd DAC via usb for those.